summaryrefslogtreecommitdiff
path: root/packages/openal/Makefile
diff options
context:
space:
mode:
authorpierre <pierre@3ad0048d-3df7-0310-abae-a5850022a9f2>2009-12-10 08:36:52 +0000
committerpierre <pierre@3ad0048d-3df7-0310-abae-a5850022a9f2>2009-12-10 08:36:52 +0000
commitc54e19a489c97317ac1fe648ce3ae5cb8e77590e (patch)
treef2cda318c01ba53fc321a180baffba3e7269c184 /packages/openal/Makefile
parent2252c0647779c58fc630c1b291b2b20db7288674 (diff)
downloadfpc-c54e19a489c97317ac1fe648ce3ae5cb8e77590e.tar.gz
* Update Makefiles
git-svn-id: http://svn.freepascal.org/svn/fpc/trunk@14385 3ad0048d-3df7-0310-abae-a5850022a9f2
Diffstat (limited to 'packages/openal/Makefile')
-rw-r--r--packages/openal/Makefile48
1 files changed, 42 insertions, 6 deletions
diff --git a/packages/openal/Makefile b/packages/openal/Makefile
index d462e9aa0a..bf466795af 100644
--- a/packages/openal/Makefile
+++ b/packages/openal/Makefile
@@ -1,10 +1,10 @@
#
-# Don't edit, this file is generated by FPCMake Version 2.0.0 [2009/08/02]
+# Don't edit, this file is generated by FPCMake Version 2.0.0 [2009/12/10]
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-qnx i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian m68k-linux m68k-freebsd m68k-netbsd m68k-amiga m68k-atari m68k-openbsd m68k-palmos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-solaris x86_64-darwin x86_64-win64 x86_64-embedded arm-linux arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian powerpc64-linux powerpc64-darwin powerpc64-embedded avr-embedded armeb-linux armeb-embedded mipsel-linux
BSDs = freebsd netbsd openbsd darwin
-UNIXs = linux $(BSDs) solaris qnx
+UNIXs = linux $(BSDs) solaris qnx haiku
LIMIT83fs = go32v2 os2 emx watcom
OSNeedsComspecToRunBatch = go32v2 watcom
FORCE:
@@ -389,6 +389,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
override TARGET_UNITS+=openal
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+override TARGET_UNITS+=openal
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
override TARGET_UNITS+=openal
endif
@@ -440,6 +443,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
override TARGET_UNITS+=openal
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+override TARGET_UNITS+=openal
+endif
ifeq ($(FULL_TARGET),i386-linux)
override TARGET_EXAMPLEDIRS+=examples
endif
@@ -563,6 +569,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
override TARGET_EXAMPLEDIRS+=examples
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+override TARGET_EXAMPLEDIRS+=examples
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
override TARGET_EXAMPLEDIRS+=examples
endif
@@ -614,6 +623,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
override TARGET_EXAMPLEDIRS+=examples
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+override TARGET_EXAMPLEDIRS+=examples
+endif
override INSTALL_FPCPACKAGE=y
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_INCLUDEDIR+=src
@@ -738,6 +750,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
override COMPILER_INCLUDEDIR+=src
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+override COMPILER_INCLUDEDIR+=src
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
override COMPILER_INCLUDEDIR+=src
endif
@@ -789,6 +804,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
override COMPILER_INCLUDEDIR+=src
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+override COMPILER_INCLUDEDIR+=src
+endif
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_SOURCEDIR+=src tests examples
endif
@@ -912,6 +930,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
override COMPILER_SOURCEDIR+=src tests examples
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+override COMPILER_SOURCEDIR+=src tests examples
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
override COMPILER_SOURCEDIR+=src tests examples
endif
@@ -963,6 +984,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
override COMPILER_SOURCEDIR+=src tests examples
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+override COMPILER_SOURCEDIR+=src tests examples
+endif
ifdef REQUIRE_UNITSDIR
override UNITSDIR+=$(REQUIRE_UNITSDIR)
endif
@@ -1853,6 +1877,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
REQUIRE_PACKAGES_RTL=1
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+REQUIRE_PACKAGES_RTL=1
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
REQUIRE_PACKAGES_RTL=1
endif
@@ -1904,6 +1931,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
REQUIRE_PACKAGES_RTL=1
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+REQUIRE_PACKAGES_RTL=1
+endif
ifdef REQUIRE_PACKAGES_RTL
PACKAGEDIR_RTL:=$(firstword $(subst /Makefile.fpc,,$(strip $(wildcard $(addsuffix /rtl/Makefile.fpc,$(PACKAGESDIR))))))
ifneq ($(PACKAGEDIR_RTL),)
@@ -1913,9 +1943,9 @@ else
UNITDIR_RTL=$(PACKAGEDIR_RTL)
endif
ifdef CHECKDEPEND
-$(PACKAGEDIR_RTL)/$(FPCMADE):
- $(MAKE) -C $(PACKAGEDIR_RTL) $(FPCMADE)
-override ALLDEPENDENCIES+=$(PACKAGEDIR_RTL)/$(FPCMADE)
+$(PACKAGEDIR_RTL)/$(OS_TARGET)/$(FPCMADE):
+ $(MAKE) -C $(PACKAGEDIR_RTL)/$(OS_TARGET) $(FPCMADE)
+override ALLDEPENDENCIES+=$(PACKAGEDIR_RTL)/$(OS_TARGET)/$(FPCMADE)
endif
else
PACKAGEDIR_RTL=
@@ -2640,6 +2670,9 @@ endif
ifeq ($(FULL_TARGET),x86_64-freebsd)
TARGET_EXAMPLEDIRS_EXAMPLES=1
endif
+ifeq ($(FULL_TARGET),x86_64-solaris)
+TARGET_EXAMPLEDIRS_EXAMPLES=1
+endif
ifeq ($(FULL_TARGET),x86_64-darwin)
TARGET_EXAMPLEDIRS_EXAMPLES=1
endif
@@ -2691,6 +2724,9 @@ endif
ifeq ($(FULL_TARGET),armeb-embedded)
TARGET_EXAMPLEDIRS_EXAMPLES=1
endif
+ifeq ($(FULL_TARGET),mipsel-linux)
+TARGET_EXAMPLEDIRS_EXAMPLES=1
+endif
ifdef TARGET_EXAMPLEDIRS_EXAMPLES
examples_all:
$(MAKE) -C examples all