summaryrefslogtreecommitdiff
path: root/avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile')
-rw-r--r--avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile79
1 files changed, 76 insertions, 3 deletions
diff --git a/avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile b/avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile
index 08b5c7f31e..f00814f7a3 100644
--- a/avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile
+++ b/avx512-0037785/packages/libndsfpc/examples/graphics/3D/BoxTest/Makefile
@@ -2,7 +2,7 @@
# Don't edit, this file is generated by FPCMake Version 2.0.0
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-netbsd m68k-amiga m68k-atari m68k-palmos m68k-macosclassic m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macosclassic powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-haiku x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded x86_64-iphonesim x86_64-android x86_64-aros x86_64-dragonfly arm-linux arm-netbsd arm-palmos arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android arm-aros arm-freertos arm-ios powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android mips64el-linux jvm-java jvm-android i8086-embedded i8086-msdos i8086-win16 aarch64-linux aarch64-darwin aarch64-win64 aarch64-android aarch64-ios wasm-wasm sparc64-linux riscv32-linux riscv32-embedded riscv64-linux riscv64-embedded xtensa-linux xtensa-embedded xtensa-freertos z80-embedded z80-zxspectrum z80-msxdos
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-netbsd m68k-amiga m68k-atari m68k-palmos m68k-macosclassic m68k-embedded m68k-sinclairql powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macosclassic powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-haiku x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded x86_64-iphonesim x86_64-android x86_64-aros x86_64-dragonfly arm-linux arm-netbsd arm-palmos arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android arm-aros arm-freertos arm-ios powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android mips64el-linux jvm-java jvm-android i8086-embedded i8086-msdos i8086-win16 aarch64-linux aarch64-darwin aarch64-win64 aarch64-android aarch64-ios wasm-wasm sparc64-linux riscv32-linux riscv32-embedded riscv64-linux riscv64-embedded xtensa-linux xtensa-embedded xtensa-freertos z80-embedded z80-zxspectrum z80-msxdos z80-amstradcpc
BSDs = freebsd netbsd openbsd darwin dragonfly
UNIXs = linux $(BSDs) solaris qnx haiku aix
LIMIT83fs = go32v2 os2 emx watcom msdos win16 atari
@@ -449,6 +449,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override TARGET_PROGRAMS+=BoxTest
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override TARGET_PROGRAMS+=BoxTest
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override TARGET_PROGRAMS+=BoxTest
endif
@@ -665,6 +668,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override TARGET_PROGRAMS+=BoxTest
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override TARGET_PROGRAMS+=BoxTest
+endif
ifeq ($(FULL_TARGET),i386-linux)
override CLEAN_UNITS+=*
endif
@@ -755,6 +761,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override CLEAN_UNITS+=*
endif
@@ -971,6 +980,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),i386-linux)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
@@ -1061,6 +1073,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
@@ -1277,6 +1292,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
+endif
override INSTALL_FPCPACKAGE=y
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_OPTIONS+=-Xm
@@ -1368,6 +1386,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override COMPILER_OPTIONS+=-Xm
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override COMPILER_OPTIONS+=-Xm
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override COMPILER_OPTIONS+=-Xm
endif
@@ -1584,6 +1605,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override COMPILER_OPTIONS+=-Xm
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override COMPILER_OPTIONS+=-Xm
+endif
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_TARGETDIR+=$(BIN)
endif
@@ -1674,6 +1698,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override COMPILER_TARGETDIR+=$(BIN)
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override COMPILER_TARGETDIR+=$(BIN)
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override COMPILER_TARGETDIR+=$(BIN)
endif
@@ -1890,6 +1917,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override COMPILER_TARGETDIR+=$(BIN)
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override COMPILER_TARGETDIR+=$(BIN)
+endif
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
@@ -1980,6 +2010,9 @@ endif
ifeq ($(FULL_TARGET),m68k-embedded)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+override COMPILER_UNITTARGETDIR+=$(BUILD)
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
@@ -2196,6 +2229,9 @@ endif
ifeq ($(FULL_TARGET),z80-msxdos)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+override COMPILER_UNITTARGETDIR+=$(BUILD)
+endif
ifdef REQUIRE_UNITSDIR
override UNITSDIR+=$(REQUIRE_UNITSDIR)
endif
@@ -2422,15 +2458,34 @@ ifneq ($(findstring sparc64,$(shell uname -a)),)
ifeq ($(BINUTILSPREFIX),)
GCCLIBDIR:=$(shell dirname `gcc -m32 -print-libgcc-file-name`)
else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
+CROSSGCCOPT=-mabi=32
+else
CROSSGCCOPT=-m32
endif
endif
endif
endif
+endif
ifdef FPCFPMAKE
FPCFPMAKE_CPU_TARGET=$(shell $(FPCFPMAKE) -iTP)
ifeq ($(CPU_TARGET),$(FPCFPMAKE_CPU_TARGET))
FPCMAKEGCCLIBDIR:=$(GCCLIBDIR)
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_TARGET),aarch64 powerpc64 riscv64 sparc64 x86_64),)
+FPCMAKE_CROSSGCCOPT=-m64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips64 mips64el),)
+FPCMAKE_CROSSGCCOPT=-mabi=64
+else
+ifneq ($(findstring $(FPCFPMAKE_CPU_OPT),mips mipsel),)
+FPCMAKE_CROSSGCCOPT=-mabi=32
+else
+FPCMAKE_CROSSGCCOPT=-m32
+endif
+endif
+endif
+FPCMAKEGCCLIBDIR:=$(shell dirname `gcc $(FPCMAKE_CROSSGCCOPT) -print-libgcc-file-name`)
endif
endif
ifndef FPCMAKEGCCLIBDIR
@@ -3201,6 +3256,15 @@ REQUIRE_PACKAGES_LIBTAR=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBNDSFPC=1
endif
+ifeq ($(FULL_TARGET),m68k-sinclairql)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_LIBTAR=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
ifeq ($(FULL_TARGET),powerpc-linux)
REQUIRE_PACKAGES_RTL=1
REQUIRE_PACKAGES_PASZLIB=1
@@ -3849,6 +3913,15 @@ REQUIRE_PACKAGES_LIBTAR=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBNDSFPC=1
endif
+ifeq ($(FULL_TARGET),z80-amstradcpc)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_LIBTAR=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
ifdef REQUIRE_PACKAGES_RTL
PACKAGEDIR_RTL:=$(firstword $(subst /Makefile.fpc,,$(strip $(wildcard $(addsuffix /rtl/Makefile.fpc,$(PACKAGESDIR))))))
ifneq ($(PACKAGEDIR_RTL),)
@@ -4132,11 +4205,11 @@ endif
ifndef CROSSBOOTSTRAP
ifneq ($(BINUTILSPREFIX),)
override FPCOPT+=-XP$(BINUTILSPREFIX)
-endif
-ifneq ($(BINUTILSPREFIX),)
+ifneq ($(RLINKPATH),)
override FPCOPT+=-Xr$(RLINKPATH)
endif
endif
+endif
ifndef CROSSCOMPILE
ifneq ($(BINUTILSPREFIX),)
override FPCMAKEOPT+=-XP$(BINUTILSPREFIX)