summaryrefslogtreecommitdiff
path: root/packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile')
-rw-r--r--packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile62
1 files changed, 61 insertions, 1 deletions
diff --git a/packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile b/packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile
index 7fc39994d7..5e8f81eaf7 100644
--- a/packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile
+++ b/packages/libndsfpc/examples/gl2d/2Dplus3D/Makefile
@@ -2,7 +2,7 @@
# Don't edit, this file is generated by FPCMake Version 2.0.0
#
default: all
-MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-netbsd m68k-amiga m68k-atari m68k-palmos m68k-macos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-haiku x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded x86_64-iphonesim x86_64-android x86_64-aros x86_64-dragonfly arm-linux arm-netbsd arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android arm-aros arm-freertos powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android jvm-java jvm-android i8086-embedded i8086-msdos i8086-win16 aarch64-linux aarch64-darwin aarch64-win64 aarch64-android wasm-wasm sparc64-linux riscv32-linux riscv32-embedded riscv64-linux riscv64-embedded xtensa-linux xtensa-embedded xtensa-freertos
+MAKEFILETARGETS=i386-linux i386-go32v2 i386-win32 i386-os2 i386-freebsd i386-beos i386-haiku i386-netbsd i386-solaris i386-netware i386-openbsd i386-wdosx i386-darwin i386-emx i386-watcom i386-netwlibc i386-wince i386-embedded i386-symbian i386-nativent i386-iphonesim i386-android i386-aros m68k-linux m68k-netbsd m68k-amiga m68k-atari m68k-palmos m68k-macos m68k-embedded powerpc-linux powerpc-netbsd powerpc-amiga powerpc-macos powerpc-darwin powerpc-morphos powerpc-embedded powerpc-wii powerpc-aix sparc-linux sparc-netbsd sparc-solaris sparc-embedded x86_64-linux x86_64-freebsd x86_64-haiku x86_64-netbsd x86_64-solaris x86_64-openbsd x86_64-darwin x86_64-win64 x86_64-embedded x86_64-iphonesim x86_64-android x86_64-aros x86_64-dragonfly arm-linux arm-netbsd arm-palmos arm-darwin arm-wince arm-gba arm-nds arm-embedded arm-symbian arm-android arm-aros arm-freertos powerpc64-linux powerpc64-darwin powerpc64-embedded powerpc64-aix avr-embedded armeb-linux armeb-embedded mips-linux mipsel-linux mipsel-embedded mipsel-android jvm-java jvm-android i8086-embedded i8086-msdos i8086-win16 aarch64-linux aarch64-darwin aarch64-win64 aarch64-android wasm-wasm sparc64-linux riscv32-linux riscv32-embedded riscv64-linux riscv64-embedded xtensa-linux xtensa-embedded xtensa-freertos z80-embedded z80-zxspectrum
BSDs = freebsd netbsd openbsd darwin dragonfly
UNIXs = linux $(BSDs) solaris qnx haiku aix
LIMIT83fs = go32v2 os2 emx watcom msdos win16 atari
@@ -650,6 +650,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override TARGET_PROGRAMS+=2Dplus3D
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override TARGET_PROGRAMS+=2Dplus3D
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override TARGET_PROGRAMS+=2Dplus3D
+endif
ifeq ($(FULL_TARGET),i386-linux)
override CLEAN_UNITS+=*
endif
@@ -941,6 +947,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override CLEAN_UNITS+=*
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override CLEAN_UNITS+=*
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override CLEAN_UNITS+=*
+endif
ifeq ($(FULL_TARGET),i386-linux)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
@@ -1232,6 +1244,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override CLEAN_FILES+=*.elf *.o *.s *.nds *.nef *.h *.bin *.map $(BUILD)/* $(INC)/* $(BIN)/*
+endif
override INSTALL_FPCPACKAGE=y
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_OPTIONS+=-Xm
@@ -1524,6 +1542,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override COMPILER_OPTIONS+=-Xm
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override COMPILER_OPTIONS+=-Xm
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override COMPILER_OPTIONS+=-Xm
+endif
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_TARGETDIR+=$(BIN)
endif
@@ -1815,6 +1839,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override COMPILER_TARGETDIR+=$(BIN)
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override COMPILER_TARGETDIR+=$(BIN)
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override COMPILER_TARGETDIR+=$(BIN)
+endif
ifeq ($(FULL_TARGET),i386-linux)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
@@ -2106,6 +2136,12 @@ endif
ifeq ($(FULL_TARGET),xtensa-freertos)
override COMPILER_UNITTARGETDIR+=$(BUILD)
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+override COMPILER_UNITTARGETDIR+=$(BUILD)
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+override COMPILER_UNITTARGETDIR+=$(BUILD)
+endif
ifdef REQUIRE_UNITSDIR
override UNITSDIR+=$(REQUIRE_UNITSDIR)
endif
@@ -2551,6 +2587,9 @@ STATICLIBEXT=.a
else
EXEEXT=.bin
endif
+ifeq ($(CPU_TARGET),z80)
+OEXT=.rel
+endif
SHORTSUFFIX=emb
endif
ifeq ($(OS_TARGET),win16)
@@ -2559,6 +2598,9 @@ STATICLIBEXT=.a
SHAREDLIBEXT=.dll
SHORTSUFFIX=w16
endif
+ifeq ($(OS_TARGET),zxspectrum)
+OEXT=.rel
+endif
ifneq ($(findstring $(OS_SOURCE),$(LIMIT83fs)),)
FPCMADE=fpcmade.$(SHORTSUFFIX)
ZIPSUFFIX=$(SHORTSUFFIX)
@@ -3687,6 +3729,24 @@ REQUIRE_PACKAGES_LIBTAR=1
REQUIRE_PACKAGES_FPMKUNIT=1
REQUIRE_PACKAGES_LIBNDSFPC=1
endif
+ifeq ($(FULL_TARGET),z80-embedded)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_LIBTAR=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
+ifeq ($(FULL_TARGET),z80-zxspectrum)
+REQUIRE_PACKAGES_RTL=1
+REQUIRE_PACKAGES_PASZLIB=1
+REQUIRE_PACKAGES_FCL-PROCESS=1
+REQUIRE_PACKAGES_HASH=1
+REQUIRE_PACKAGES_LIBTAR=1
+REQUIRE_PACKAGES_FPMKUNIT=1
+REQUIRE_PACKAGES_LIBNDSFPC=1
+endif
ifdef REQUIRE_PACKAGES_RTL
PACKAGEDIR_RTL:=$(firstword $(subst /Makefile.fpc,,$(strip $(wildcard $(addsuffix /rtl/Makefile.fpc,$(PACKAGESDIR))))))
ifneq ($(PACKAGEDIR_RTL),)