summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolaus Waxweiler <madigens@gmail.com>2018-06-10 13:19:31 +0100
committerNikolaus Waxweiler <madigens@gmail.com>2018-06-10 13:29:01 +0100
commitbfbde7926f2c1f6b4da058ed4cd0e91c6697096c (patch)
tree658268350117bc39259bea26484af7ca0f11aaaa /CMakeLists.txt
parent6732f05593930621081092c7e2c2ec8ec043cc2d (diff)
downloadfreetype2-bfbde7926f2c1f6b4da058ed4cd0e91c6697096c.tar.gz
CMakeLists: also accept IOS_PLATFORM=SIMULATOR64
This might be needed to build FreeType for the iOS simulator. See https://savannah.nongnu.org/bugs/index.php?54048. Patch contributed by Steve Robinson. * CMakeLists.txt: Accept IOS_PLATFORM=SIMULATOR64
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cfba113d1..f54e68871 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,10 @@
#
# cmake -E chdir build cmake -G Xcode -D IOS_PLATFORM=SIMULATOR ..
#
+# or
+#
+# cmake -E chdir build cmake -G Xcode -D IOS_PLATFORM=SIMULATOR64 ..
+#
# Finally, build the project with:
#
# cmake --build build
@@ -96,9 +100,10 @@ include(CheckIncludeFile)
if (APPLE)
if (DEFINED IOS_PLATFORM)
if (NOT "${IOS_PLATFORM}" STREQUAL "OS"
- AND NOT "${IOS_PLATFORM}" STREQUAL "SIMULATOR")
+ AND NOT "${IOS_PLATFORM}" STREQUAL "SIMULATOR"
+ AND NOT "${IOS_PLATFORM}" STREQUAL "SIMULATOR64")
message(FATAL_ERROR
- "IOS_PLATFORM must be set to either OS or SIMULATOR")
+ "IOS_PLATFORM must be set to either OS, SIMULATOR, or SIMULATOR64")
endif ()
if (NOT "${CMAKE_GENERATOR}" STREQUAL "Xcode")
message(AUTHOR_WARNING