summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Bock <alexander.j.bock@nasa.gov>2015-11-27 06:34:39 +0100
committerWerner Lemberg <wl@gnu.org>2015-11-27 06:34:39 +0100
commit8f982b388168f7945e65c7a75e4dec5f167cb42d (patch)
tree230f2fd35d8e796f187dcac79016fe4c13724d21 /CMakeLists.txt
parent7696e337ee77685f48f7b805afa44a5dec3cc78e (diff)
downloadfreetype2-8f982b388168f7945e65c7a75e4dec5f167cb42d.tar.gz
CMakeLists.txt: Honour new command line flag `FREETYPE_NO_DIST'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a96ef6f9..1577b9f3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,6 +58,9 @@
#
# . `CMakeLists.txt' is provided as-is since it is normally not used by the
# developer team.
+#
+# . If you want to disable the automatic generation of the distribution
+# targets, add the `-D FREETYPE_NO_DIST=true' command line argument.
cmake_minimum_required(VERSION 2.6)
@@ -391,8 +394,9 @@ set(CPACK_GENERATOR TGZ)
include(CPack)
-# add make dist target
-add_custom_target(dist COMMAND ${CMAKE_MAKE_PROGRAM} package_source)
-
+# Add `make dist' target if FREETYPE_DIST is set (which is the default)
+if (NOT DEFINED FREETYPE_NO_DIST)
+ add_custom_target(dist COMMAND ${CMAKE_MAKE_PROGRAM} package_source)
+endif ()
# eof