summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Turner <david@freetype.org>2020-05-18 09:33:38 +0200
committerWerner Lemberg <wl@gnu.org>2020-05-18 18:42:57 +0200
commit62fea391fa9993f8c1d206a50080d690178ce518 (patch)
treeeeda8de5b5d74b5cffc3c671d0c1bb8959902d0d /CMakeLists.txt
parent4eee13404dca62cdaed4e26b5523f0d8f92f2a1f (diff)
downloadfreetype2-62fea391fa9993f8c1d206a50080d690178ce518.tar.gz
Remove obsolete HAVE_STDINT_H probing macro.
This macro was updated by the unix configure script and the `CMakeLists.txt' one, but is never used in the source tree (nor is <stdint.h> included anywhere). * CMakeLists.txt, builds/unix/ftconfig.in: Don't handle `HAVE_STDINT_H'.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7aec4d05..17787a171 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -240,7 +240,6 @@ endif ()
if (UNIX)
check_include_file("unistd.h" HAVE_UNISTD_H)
check_include_file("fcntl.h" HAVE_FCNTL_H)
- check_include_file("stdint.h" HAVE_STDINT_H)
file(READ "${PROJECT_SOURCE_DIR}/builds/unix/ftconfig.in"
FTCONFIG_H)
@@ -254,11 +253,6 @@ if (UNIX)
"#undef +(HAVE_FCNTL_H)" "#define \\1 1"
FTCONFIG_H "${FTCONFIG_H}")
endif ()
- if (HAVE_STDINT_H)
- string(REGEX REPLACE
- "#undef +(HAVE_STDINT_H)" "#define \\1 1"
- FTCONFIG_H "${FTCONFIG_H}")
- endif ()
string(REPLACE "/undef " "#undef "
FTCONFIG_H "${FTCONFIG_H}")
else ()