summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Jing <@CPUcontrol>2022-02-02 18:14:19 +0100
committerWerner Lemberg <wl@gnu.org>2022-02-02 18:15:28 +0100
commit56d182a74d90cde8753d5ec28d37f748f909c729 (patch)
tree080fa38b74b02c8f547e99b82327559d07055738 /CMakeLists.txt
parent8e39e42ee94ec4c81499e4d871f802fbfa0745df (diff)
downloadfreetype2-56d182a74d90cde8753d5ec28d37f748f909c729.tar.gz
[cmake] Fix build on MacOS.
* CMakeLists.txt (CMAKE_OSX_ARCHITECTURES): Update value to fix the building of a framework on MacOS. * builds/mac/freetype-Info.plist (CFBundleExecutable): Make identifier lowercase only. Fixes #1127.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8cb778396..85babddbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -240,7 +240,7 @@ if (BUILD_FRAMEWORK)
message(FATAL_ERROR
"You should use Xcode generator with BUILD_FRAMEWORK enabled")
endif ()
- set(CMAKE_OSX_ARCHITECTURES "$(ARCHS_STANDARD_32_64_BIT)")
+ set(CMAKE_OSX_ARCHITECTURES "$(ARCHS_STANDARD)")
set(BUILD_SHARED_LIBS ON)
endif ()