summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWerner Lemberg <wl@gnu.org>2015-06-28 11:06:47 +0200
committerWerner Lemberg <wl@gnu.org>2015-06-28 11:06:47 +0200
commit2c89e2c97b3be9459b9867a8a9a59c4f46653389 (patch)
tree46ec07ccbd028409ec4bf2f818d755e3bdf9e301 /CMakeLists.txt
parent52c9b1aaf39c784dd9e6adbcadf2a8dfe4ad1655 (diff)
downloadfreetype2-2c89e2c97b3be9459b9867a8a9a59c4f46653389.tar.gz
* CMakeLists.txt: Improve MSVC support (#43737).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 218b44090..dc2a74f01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -303,6 +303,12 @@ if (BUILD_FRAMEWORK)
endif ()
+if (MSVC)
+ set_target_properties(freetype PROPERTIES
+ COMPILE_FLAGS /Fd"$(IntDir)$(TargetName).pdb")
+endif ()
+
+
if (ZLIB_FOUND)
target_link_libraries(freetype ${ZLIB_LIBRARIES})
include_directories(${ZLIB_INCLUDE_DIRS})