summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWerner Lemberg <wl@gnu.org>2013-11-13 08:55:46 +0100
committerWerner Lemberg <wl@gnu.org>2013-11-13 08:55:46 +0100
commitfae382076409db198dfbff36ac4cbb97b05b30a1 (patch)
treed1924a22a506a26999259c56e49ed9f7727a84e1 /CMakeLists.txt
parentea5c781afaba862426a077ace7382a3e5381f1b3 (diff)
downloadfreetype2-fae382076409db198dfbff36ac4cbb97b05b30a1.tar.gz
Simplify header file hierarchy.
This large patch changes the header file directory layout from `include/freetype/...' to `include/...', effectively removing one level. Since the file `ft2build.h' is also located in `include' (and it stays there even after installation), all FreeType header files are now in a single directory. Applications that use (a) `freetype-config' or FreeType's `pkg-config' file to get the include directory for the compiler, and (b) the documented way for header inclusion like #include <ft2build.h> #include FT_FREETYPE_H ... don't need any change to the source code. * include/freetype/*: Move up to... * include/*: ... this directory. * builds/amiga/include/freetype/*: Move up to... * builds/amiga/include/*: ... this directory. */*: Essentially do `s@/freetype/@/@' where appropriate. * CMakeList.txt: Simplify. * builds/unix/freetype-config.in, builds/unix/freetype2.in: For `--cflags', return a single directory. * builds/unix/install.mk (install): No longer try to remove `cache' and `internal' subdirectories; instead, remove the `freetype' subdirectory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a07ce233..2c9dd4b13 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,6 @@ add_definitions(-DFT2_BUILD_LIBRARY)
# Specify library include directories
include_directories("${PROJECT_SOURCE_DIR}/include")
-include_directories("${PROJECT_SOURCE_DIR}/include/freetype")
# Create the configuration file
message(STATUS "Creating directory, ${PROJECT_BINARY_DIR}/include.")
@@ -129,14 +128,8 @@ include_directories("src/psnames")
add_library(freetype ${BASE_SRCS})
# Installations
-install(FILES ${PROJECT_SOURCE_DIR}/include/ft2build.h
- DESTINATION include
-)
-# Is this next needed?
-install(FILES ${PROJECT_BINARY_DIR}/include/ftconfig.h
- DESTINATION include
-)
-install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/freetype
+# Note the trailing slash in the argument to the `DIRECTORY' directive
+install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/
DESTINATION include/freetype2
PATTERN "internal" EXCLUDE
)