summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolaus Waxweiler <madigens@gmail.com>2018-05-07 23:10:36 +0100
committerNikolaus Waxweiler <madigens@gmail.com>2018-05-08 07:46:19 +0100
commitf7b4fb3a214c15df0579979bd1bd4e7f613f0209 (patch)
treec3da016490e198a82af61b15fa4e58cf65d6a62a /CMakeLists.txt
parent7702edf793ed47effbb26050d66cb2acfcde2b96 (diff)
downloadfreetype2-f7b4fb3a214c15df0579979bd1bd4e7f613f0209.tar.gz
CMake: Allow using project as subfolder in other project
* CMakeLists.txt: Test for CMake build directory being diffent from source directory. Provide other parts of the build system access the full include directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f3fef7d5..cfba113d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,7 +153,7 @@ option(FT_WITH_HARFBUZZ "Improve auto-hinting of OpenType fonts." OFF)
# Disallow in-source builds
-if ("${PROJECT_BINARY_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}")
+if ("${CMAKE_BINARY_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
message(FATAL_ERROR
"In-source builds are not permitted! Make a separate folder for"
" building, e.g.,\n"
@@ -356,17 +356,17 @@ if (BUILD_SHARED_LIBS)
SOVERSION ${LIBRARY_SOVERSION})
endif ()
-target_include_directories(
- freetype BEFORE # Pick up ftconfig.h and ftoption.h generated above.
- PRIVATE "${PROJECT_BINARY_DIR}/include")
-
+# Pick up ftconfig.h and ftoption.h generated above, first.
target_include_directories(
freetype
- PRIVATE "${PROJECT_SOURCE_DIR}/include")
+ PUBLIC
+ $<INSTALL_INTERFACE:include/freetype2>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_BINARY_DIR}/include>
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+ PRIVATE
+ ${CMAKE_CURRENT_BINARY_DIR}/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/include)
-target_include_directories(
- freetype
- PUBLIC $<INSTALL_INTERFACE:include/freetype2>)
if (BUILD_FRAMEWORK)
set_property(SOURCE ${PUBLIC_CONFIG_HEADERS}