summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2018-03-05 12:33:34 +0800
committerWerner Lemberg <wl@gnu.org>2018-03-09 06:51:38 +0100
commit6f854692a86a778a1b88289fbad75666b6eec621 (patch)
tree788c84657b1c4b74879183c1f644721ad3b2b6a1 /CMakeLists.txt
parente277267c5229beaa911e9fb8b16fb80530c83ead (diff)
downloadfreetype2-6f854692a86a778a1b88289fbad75666b6eec621.tar.gz
* CMakeLists.txt [win32]: Allow MSVC DLL builds (#53287).
Do not limit DLL builds to MinGW, since we already have `__declspec(dllexport)' directives in `ftconfig.h'. Also suppress more warnings for POSIX functions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83f26b94b..f335fec18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -119,10 +119,6 @@ endif ()
project(freetype)
-if (WIN32 AND NOT MINGW AND BUILD_SHARED_LIBS)
- message(FATAL_ERROR "Building shared libraries on Windows needs MinGW")
-endif ()
-
# Disallow in-source builds
if ("${PROJECT_BINARY_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}")
message(FATAL_ERROR
@@ -164,6 +160,7 @@ set(SHARED_LIBRARY_VERSION ${VERSION_MAJOR}.${VERSION_MINOR})
add_definitions(-DFT2_BUILD_LIBRARY)
if (WIN32)
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
+ add_definitions(-D_CRT_NONSTDC_NO_WARNINGS)
endif ()