summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-02-10 09:30:40 -0500
committerWerner Lemberg <wl@gnu.org>2021-02-10 18:14:47 +0100
commitcc90307d7140867479428bc21861240cfe66cfec (patch)
tree0f45965f49074ab45e4edfa1fabb4b0f5c9649d1 /meson.build
parent3dbdb78a25850b8a7fe86ccc17987c9eacac1470 (diff)
downloadfreetype2-cc90307d7140867479428bc21861240cfe66cfec.tar.gz
* meson.build: s/freetype2_dep/freetype_dep/.
Many projects (e.g., fontconfig, cairo) hardcode the `freetype_dep` variable name to use FreeType as subproject because that was the variable name in Centricular's Meson port of FreeType. While they should stop hardcoding that variable name, it does not cost us anything to keep using that name to ease transition.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c2c8f7bc3..dc322553b 100644
--- a/meson.build
+++ b/meson.build
@@ -327,11 +327,11 @@ ft2_lib = library('freetype',
# To be used by other projects including this one through subproject().
-freetype2_dep = declare_dependency(
+freetype_dep = declare_dependency(
include_directories: ft2_includes,
link_with: ft2_lib,
version: ft2_pkgconfig_version)
-meson.override_dependency('freetype2', freetype2_dep)
+meson.override_dependency('freetype2', freetype_dep)
# NOTE: Using both `install_dir` and `subdir` doesn't seem to work below,