summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTorsten Hilbrich <emacs.nolkaf@hilbrich.tk>2021-01-06 08:55:16 +0100
committerWerner Lemberg <wl@gnu.org>2021-01-06 08:55:16 +0100
commitc6345ca36de9d396b4dbef2aeab73a5a838c46b6 (patch)
treebe3f1e05552823aee3668cf4ac61632a0aa2c7da /meson.build
parent74f1b6be4a91ec9e105d9c2a11e5ba124b698755 (diff)
downloadfreetype2-c6345ca36de9d396b4dbef2aeab73a5a838c46b6.tar.gz
* meson.build: Fix 'png' build option (#59458).
Without this patch, 'png' is always required.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d0f5783fe..895ebb397 100644
--- a/meson.build
+++ b/meson.build
@@ -264,8 +264,10 @@ endif
# PNG support
libpng_dep = dependency('libpng', required: get_option('png'))
-ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_PNG']
-ft2_deps += [libpng_dep]
+if libpng_dep.found()
+ ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_PNG']
+ ft2_deps += [libpng_dep]
+endif
# Harfbuzz support
harfbuzz_dep = dependency('harfbuzz',