summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMoazin Khatti <moazinkhatri@gmail.com>2021-12-25 20:14:11 -0800
committerWerner Lemberg <wl@gnu.org>2022-01-20 16:45:18 +0000
commit0bf49bd229427b56ab61e8e2c08f3fe448286890 (patch)
tree6a5b1201f3acf26b9b5d84b7e04ef32b58fb2137 /meson.build
parent97c09a803eb6cd44456e0251529db2ae96a019f8 (diff)
downloadfreetype2-0bf49bd229427b56ab61e8e2c08f3fe448286890.tar.gz
Add 'svg' module for OT-SVG rendering.
* CMakeLists.txt (BASE_SRCS): Add svg module file. * meson.build (ft2_public_headers): Add `otsvg.h`. * modules.cfg (RASTER_MODULES): Add `svg` module. * builds/meson/parse_modules_cfg.py: Add svg module. * include/freetype/config/ftmodule.h: Add `ft_svg_renderer_class`. * include/freetype/fterrdef.h: Add `Invalid_SVG_Document` and `Missing_SVG_Hooks` error codes. * include/freetype/internal/fttrace.h: Add tracing for `otsvg`. * include/freetype/internal/svginterface.h: New file. It adds an interface to enable the presetting hook from the `base` module. * include/freetype/otsvg.h (SVG_Lib_Init_Func, SVG_Lib_Free_Func, SVG_Lib_Render_Func, SVG_Lib_Preset_Slot_Func): New hooks for SVG rendering. (SVG_RendererHooks): New structure to access them. * src/base/ftobjs.c: Include `svginterface.h`. (ft_glyphslot_preset_bitmap): Add code for presetting the slot for SVG glyphs. (ft_add_renderer): Updated. * src/svg/*: New files.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 53656d10d..5bf94c30c 100644
--- a/meson.build
+++ b/meson.build
@@ -172,6 +172,7 @@ ft2_public_headers = files([
'include/freetype/fttrigon.h',
'include/freetype/fttypes.h',
'include/freetype/ftwinfnt.h',
+ 'include/freetype/otsvg.h',
'include/freetype/t1tables.h',
'include/freetype/ttnameid.h',
'include/freetype/tttables.h',