summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-02-10 09:25:42 -0500
committerWerner Lemberg <wl@gnu.org>2021-02-10 18:10:59 +0100
commit3dbdb78a25850b8a7fe86ccc17987c9eacac1470 (patch)
treeedc1b32a4fd6367d022a32328c122b7cb029be35 /meson.build
parent2c40559609c102a934c1f0c5ee7ccb790fc887dc (diff)
downloadfreetype2-3dbdb78a25850b8a7fe86ccc17987c9eacac1470.tar.gz
[meson] Fix handling of HarfBuzz library.
* meson.build (harfbuzz_dep): Do not fall back to HarfBuzz by default. Otherwise it causes a dependency cycle: cairo => fontconfig => freetype2 => harfbuzz => cairo Meson will still fall back to HarfBuzz subprojects if the `harfbuzz` option is set to `enabled` instead of `auto` and a `subprojects/harfbuzz.wrap` file is present. In that case it is the responsibility of the main project to set the proper options on each subproject to break the dependency cycle. Fixes: #1028.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0116572bd..c2c8f7bc3 100644
--- a/meson.build
+++ b/meson.build
@@ -260,10 +260,7 @@ endif
# Harfbuzz support
harfbuzz_dep = dependency('harfbuzz',
version: '>= 2.0.0',
- required: get_option('harfbuzz'),
- fallback: ['harfbuzz', 'libharfbuzz_dep'],
- default_options : ['freetype=disabled',
- 'fontconfig=disabled'])
+ required: get_option('harfbuzz'))
if harfbuzz_dep.found()
ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ']
ft2_deps += [harfbuzz_dep]