summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-10-26 11:26:04 -0400
committerWerner Lemberg <wl@gnu.org>2021-02-09 16:09:04 +0100
commit5c81e09b17ce85ca6d0a3d0b6d3684bb52d7e6df (patch)
treebfb29588180b60da6485bf2029ffc42254576f55 /meson.build
parent1b69fb9bdb78265707b00e97ab274c42a2334670 (diff)
downloadfreetype2-5c81e09b17ce85ca6d0a3d0b6d3684bb52d7e6df.tar.gz
* meson.build (bzip2_dep): Simplify.
We remove `static:false` from `find_library('bz2')`. I don't know whether the previous code was a workaround for an old meson bug, but at least with version >=0.55.0 (which FreeType uses) it picks the shared library when both are available. With this commit, file `freetype2.pc` no longer contains the full path to file `libbz2.so`; instead, it correctly uses `-lbz2`. Note that this is a meson bug is still present in the current version (0.57.0).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index dac0e6b11..243046cf1 100644
--- a/meson.build
+++ b/meson.build
@@ -250,14 +250,7 @@ else
endif
# BZip2 support
-#
-# IMPORTANT NOTE: Without `static: false` here, Meson will find both the
-# static library version and the shared library version when they are
-# installed on the system, and will try to link them *both* to the final
-# library!
-bzip2_dep = meson.get_compiler('c').find_library('bz2',
- static: false,
- required: get_option('bzip2'))
+bzip2_dep = cc.find_library('bz2', required: get_option('bzip2'))
if bzip2_dep.found()
ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_BZIP2']
ft2_sources += files(['src/bzip2/ftbzip2.c',])