summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDavid Turner <david@freetype.org>2021-06-15 23:12:57 +0200
committerDavid Turner <david@freetype.org>2021-06-16 10:28:47 +0200
commit6f273f68788265b2bf0a127be68062f5eaccbb1b (patch)
tree15ef2ed0fa826f5961e6d5da508509deea23ce8d /meson.build
parentc6fcd61228ea349e76aa4f09442c431308da3262 (diff)
downloadfreetype2-6f273f68788265b2bf0a127be68062f5eaccbb1b.tar.gz
[meson] Add first regression test to FreeType
* tests/README.md: documentation explaining how to build and run the tests with the Meson build. * tests/scripts/download-test-fonts.sh: Simple script to download test font files to the 'tests/data/' folder. * meson.build, meson_options.txt, tests/meson.build: Add 'tests' option to enable building and running the test programs, disabled by default. * tests/issue-1063/main.c: Simple regression test to exhibit issue 1063. * .gitignore: Ignore the content of the tests/data/ folder for now.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c5529a655..152024de0 100644
--- a/meson.build
+++ b/meson.build
@@ -369,6 +369,9 @@ pkgconfig.generate(ft2_lib,
version: ft2_pkgconfig_version,
)
+if get_option('tests').enabled()
+ subdir('tests')
+endif
# NOTE: Unlike the old `make refdoc` command, this generates the
# documentation under `$BUILD/docs/` since Meson doesn't support modifying