summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2022-05-27 11:26:30 -0400
committerWerner Lemberg <wl@gnu.org>2022-06-21 08:09:16 +0200
commitb861b24157d3b58368f102dc3632edd7d6e7438f (patch)
treecd374d579f20b17306bb6e168cd6f775ffbb504d /meson.build
parent47103b2f195e0f9664c9470182f063cb7d41dc9f (diff)
downloadfreetype2-b861b24157d3b58368f102dc3632edd7d6e7438f.tar.gz
[meson] Disable FreeType in HarfBuzz fallback.
This avoids cyclic subproject configuration when the 'harfbuzz' feature is enabled, or `--wrap-mode=forcefallback` is used, but HarfBuzz is built as a subproject. HarfBuzz does the same and disables HarfBuzz support when configuring FreeType as a subproject. * meson.build (harfbuzz_dep): Implement it. * subprojects/harfbuzz.wrap: New file. * .gitlab-ci.yml [windows meson]: Use latest version of the meson 0.59 series, which has a necessary bug fix to make CI work.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a066325b4..41822bc2b 100644
--- a/meson.build
+++ b/meson.build
@@ -335,7 +335,8 @@ endif
# Harfbuzz support
harfbuzz_dep = dependency('harfbuzz',
version: '>= 2.0.0',
- required: get_option('harfbuzz'))
+ required: get_option('harfbuzz'),
+ default_options: ['freetype=disabled'])
if harfbuzz_dep.found()
ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ']