summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorDavid Turner <david@freetype.org>2021-08-17 17:27:36 +0200
committerWerner Lemberg <wl@gnu.org>2022-01-09 21:38:29 +0100
commit0d34386366c93835501e98d643586eb32dbda1fa (patch)
treea7eeffcc719be575246c52cb1ba5d96501444bf8 /meson_options.txt
parentd276bcb7f0c02c20d3585b2e5626702df6d140a6 (diff)
downloadfreetype2-0d34386366c93835501e98d643586eb32dbda1fa.tar.gz
[meson] Change Zlib configuration option.
* meson_options.txt, meson.build: Change the format of the 'zlib' meson build configuration option to be a combo with the following choices: - none: Do not support gzip-compressed streams at all. - internal: Support gzip-compressed streams using the copy of the gzip sources under `src/gzip/`; this should only be used during development to ensure these work properly. - external: Support gzip-compressed streams using the 'zlib' Meson subproject, linked as a static library. - system: Support gzip-compressed streams using a system-installed version of zlib. - auto: Support gzip-compressed streams using a system-installed version of zlib, if available, or using the 'zlib' subproject otherwise. This is the default. - disabled: Backward-compatible alias for 'none'. - enabled: Backward-compatible alias for 'auto'.
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 375eb714e..50ca0f986 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -46,8 +46,10 @@ option('tests',
description: 'Enable FreeType unit and regression tests')
option('zlib',
- type: 'feature',
- value: 'auto',
+ type: 'combo',
+ choices: [ 'auto', 'none',
+ 'internal', 'external', 'system',
+ 'disabled', 'enabled' ],
description: 'Support reading gzip-compressed font files')
# EOF