summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-10-26 14:56:05 -0400
committerWerner Lemberg <wl@gnu.org>2021-02-09 16:11:39 +0100
commit2c40559609c102a934c1f0c5ee7ccb790fc887dc (patch)
tree056fd93e49cc2201caf3d270c21e7d589568e75f /meson_options.txt
parente11cc40a2eab0af601f75259da45e1ffb44b11c4 (diff)
downloadfreetype2-2c40559609c102a934c1f0c5ee7ccb790fc887dc.tar.gz
Meson: Fix dependency lookup and generate ftconfig.h
[meson] Fix dependency lookup and generate `ftconfig.h`. - zlib: If not found on the system, meson can build it as a subproject. We thus never use the (outdated) zlib support that comes with FreeType. Doing so has the additional advantage that the zlib code can be shared with other projects like GLib if both are subprojects of an application. - harfbuzz: Build as a subproject if not found on the system. - 'QUESTION: What if the compiler doesn't support `-D` but uses `/D` instead as on Windows?' Answer: Meson translate arguments for us. - visibility: Replace self-made code with meson-specific solution. * meson.build (ft2_defines): Rewrite logic to set and handle it. (process_header_command): New variable, previously called `ftoption_command`. (ftoption_command, ftconfig_command): New variables. (zlib_option): Removed. (zlib_dep): New variable. (ft2_deps): Updated. (harfbuzz_dep): Updated. (ftconfig_h_in, ftconfig_h): New variables. (ft2_sources): Updated. (ft2_lib): Updated, handle visibility. (summary): Updted. * meson_options.txt (zlib): Updated.
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 301acdccb..f0fc50a38 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -13,8 +13,7 @@
option('zlib',
- type: 'combo',
- choices: ['disabled', 'auto', 'builtin', 'system'],
+ type: 'feature',
value: 'auto',
description: 'Support reading gzip-compressed font files.')