summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-02-08 09:21:10 +0100
committerJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-02-08 09:21:10 +0100
commit2dce17ca688920d26694336de74ebd7bcfc0aa20 (patch)
treed5ae311ce545adec5ce186f1324c262b1b14ed31 /CMakeLists.txt
parent9c4ae62976adec2eb00f3e7c51f8dcfc986db390 (diff)
downloadgawk-2dce17ca688920d26694336de74ebd7bcfc0aa20.tar.gz
Added test/CMakeLists.txt and doc/CMakeLists.txt with FSF header.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 217097fa..13ff8a59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,29 @@
+#
+# CMakeLists.txt --- CMake input file for gawk
+#
+# Copyright (C) 2013
+# the Free Software Foundation, Inc.
+#
+# This file is part of GAWK, the GNU implementation of the
+# AWK Programming Language.
+#
+# GAWK is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# GAWK is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+#
+
+## process this file with CMake to produce Makefile
+
cmake_minimum_required (VERSION 2.6)
project (gawk C)
@@ -244,3 +270,5 @@ set (GAWK_SOURCES ${GAWK_SOURCES}
add_executable (gawk ${GAWK_SOURCES})
target_link_libraries (gawk m ${EXTRA_LIBS})
+add_subdirectory(test)
+add_subdirectory(doc)