summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2017-09-12 21:41:47 +0300
committerArnold D. Robbins <arnold@skeeve.com>2017-09-12 21:41:47 +0300
commit93958d05203b28b06a664f96dffae96ef399495f (patch)
tree29157919f901ebf65aa2ce008c2337d0b2806672 /Makefile.am
parent1a22bc25e66bf8cf7dd76aaa19b59cafdc746dc0 (diff)
downloadgawk-93958d05203b28b06a664f96dffae96ef399495f.tar.gz
Serialize running bison in parallel builds.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d2efd18..1040a77e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,9 +193,9 @@ awkgram.c: awkgram.y
if cmp -s y.tab.h $*.h; then rm -f y.tab.h; else mv y.tab.h $*.h; fi; \
else :; fi
-command.c: command.y
- $(YACC) -p zz $<
- sed 's/parse error/syntax error/g' < y.tab.c | awk -f "$(srcdir)"/bisonfix.awk command > $*.c && rm y.tab.c
+command.c: command.y awkgram.c
+ $(YACC) -o $@ -p zz $<
+ sed 's/parse error/syntax error/g' < $@ > $@.tmp && mv $@.tmp $@
# This is for my development & testing.
efence: gawk