summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew J. Schorr <aschorr@telemetry-investments.com>2012-03-20 10:46:03 -0400
committerAndrew J. Schorr <aschorr@telemetry-investments.com>2012-03-20 10:46:03 -0400
commitb51edf37c4271bf5ec5dcad9d35169f55e38efa9 (patch)
tree66653936b87078aa96a562e05f66660b4d616d8e /Makefile.am
parentcd44d957787e162df4348028c22e8b9621000790 (diff)
downloadgawk-b51edf37c4271bf5ec5dcad9d35169f55e38efa9.tar.gz
- Add new environment variable AWKLIBPATH to use when searching for shared
libraries. - Instead of hardcoding the default ".so" suffix for shared libraries, use autoconf to get the right value for this platform. - Build and install some of the bundled shared library extensions so that they will now be available using the default AWKLIBPATH.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b9470617..11932aa4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,7 +48,6 @@ EXTRA_DIST = \
config.rpath \
config.sub \
depcomp \
- extension \
m4 \
missing \
missing_d \
@@ -76,6 +75,7 @@ SUBDIRS = \
awklib \
doc \
po \
+ extension \
test
# what to make and install
@@ -136,7 +136,11 @@ pkgdatadir = $(datadir)/awk
# stuff for compiling gawk/pgawk
DEFPATH='".$(PATH_SEPARATOR)$(pkgdatadir)"'
-DEFS= -DDEFPATH=$(DEFPATH) -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR='"$(datadir)/locale"'
+# shared library support:
+SHLIBEXT = "\"$(acl_shlibext)"\"
+DEFLIBPATH="\"$(pkgextensiondir)\""
+
+DEFS= -DDEFPATH=$(DEFPATH) -DDEFLIBPATH=$(DEFLIBPATH) -DSHLIBEXT=$(SHLIBEXT) -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR='"$(datadir)/locale"'
# Get rid of core files when cleaning
CLEANFILES = core core.*