summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjohn haque <j.eh@mchsi.com>2012-04-17 13:00:13 -0500
committerjohn haque <j.eh@mchsi.com>2012-04-17 13:00:13 -0500
commitb1062311a3caab9ec89c0f104bd9b4334174f23c (patch)
tree08a64713888026fb80fd80360343a51aebd8a593 /configure.ac
parente729adf120f279fd65578a410ca8d2d93a56f0f0 (diff)
parentf0345a29c71a3215adaa0e2fdfefc0c439ea6561 (diff)
downloadgawk-b1062311a3caab9ec89c0f104bd9b4334174f23c.tar.gz
Merge branch 'master' into gawk_mpfr.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7e07a791..e4ab7f44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl
dnl configure.ac --- autoconf input file for gawk
dnl
-dnl Copyright (C) 1995-2011 the Free Software Foundation, Inc.
+dnl Copyright (C) 1995-2012 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -237,6 +237,9 @@ dnl AC_MSG_ERROR([Cannot find a type to use in place of socklen_t])
])
TYPE_SOCKLEN_T
+dnl Check for C11 _Noreturn
+GAWK_AC_NORETURN
+
dnl checks for functions
AC_FUNC_VPRINTF
AC_FUNC_MKTIME
@@ -268,7 +271,7 @@ AC_CHECK_FUNCS(atexit btowc fmod getgrent getgroups grantpt \
memset_ulong mkstemp setenv setlocale setsid snprintf strchr \
strerror strftime strncasecmp strcoll strtod strtoul \
system tmpfile towlower towupper tzset usleep wcrtomb \
- wcscoll wcscoll wctype)
+ wcscoll wctype)
dnl this check is for both mbrtowc and the mbstate_t type, which is good
AC_FUNC_MBRTOWC