summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am25
1 files changed, 21 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index cc99dfa9..1099a620 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -225,6 +225,17 @@ EXTRA_DIST = \
convfmt.ok \
crlf.awk \
crlf.ok \
+ csv1.awk \
+ csv1.in \
+ csv1.ok \
+ csv2.awk \
+ csv2.ok \
+ csv3.awk \
+ csv3.in \
+ csv3.ok \
+ csvodd.awk \
+ csvodd.in \
+ csvodd.ok \
datanonl.awk \
datanonl.in \
datanonl.ok \
@@ -1403,6 +1414,8 @@ EXTRA_DIST = \
typeof5.ok \
typeof6.awk \
typeof6.ok \
+ unicode1.awk \
+ unicode1.ok \
uninit2.awk \
uninit2.ok \
uninit3.awk \
@@ -1506,7 +1519,8 @@ GAWK_EXT_TESTS = \
arraysort2 arraytype asortbool backw badargs beginfile1 beginfile2 \
asortsymtab \
binmode1 charasbytes clos1way clos1way2 clos1way3 clos1way4 \
- clos1way5 clos1way6 colonwarn commas crlf dbugeval dbugeval2 \
+ clos1way5 clos1way6 colonwarn commas crlf csv1 csv2 csv3 csvodd \
+ dbugeval dbugeval2 \
dbugeval3 dbugeval4 dbugtypedre1 dbugtypedre2 delsub \
devfd devfd1 devfd2 dfacheck1 dumpvars \
elemnew1 elemnew2 elemnew3 errno exit fieldwdth forcenum fpat1 fpat2 \
@@ -1537,7 +1551,7 @@ GAWK_EXT_TESTS = \
symtab3 symtab4 symtab5 symtab6 symtab7 symtab8 symtab9 symtab10 \
symtab11 symtab12 timeout typedregex1 typedregex2 typedregex3 \
typedregex4 typedregex5 typedregex6 typeof1 typeof2 typeof3 \
- typeof4 typeof5 typeof6 watchpoint1
+ typeof4 typeof5 typeof6 unicode1 watchpoint1
ARRAYDEBUG_TESTS = arrdbg
@@ -1604,9 +1618,12 @@ NEED_SANDBOX = sandbox1
# List of tests that need --traditional
NEED_TRADITIONAL = litoct tradanch rscompat
-# Lists of tests that need the PMA allocator and a backing file
+# List of tests that need the PMA allocator and a backing file
NEED_PMA = pma
+# List of tests that need --csv
+NEED_CSV = csv1 csv2 csv3 csvodd
+
# Lists of tests that run a shell script
RUN_SHELL = exit fflush localenl modifiers next randtest rtlen rtlen01
@@ -1625,7 +1642,7 @@ NEED_LOCALE_EN = \
backbigs1 backsmalls1 backsmalls2 commas concat4 dfamb1 ignrcas2 lc_num1 \
mbfw1 mbprintf1 mbprintf3 mbprintf4 mbstr1 mbstr2 posix_compare \
printhuge reint2 rri1 subamp subi18n wideidx wideidx2 \
- widesub widesub2 widesub3 widesub4
+ widesub widesub2 widesub3 widesub4 unicode1
# Unused at the moment, since nlstringtest has additional stuff it does
# NEED_LOCALE_FR =