summaryrefslogtreecommitdiff
path: root/boehm-gc/Makefile.am
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-16 07:35:00 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2004-06-16 07:35:00 +0000
commitc1513f4f05dc3f73c3a1ad391d9c6f5b9f877654 (patch)
tree78d00ee8f89fa1e592854e16a7fe6fcf6d01e3fe /boehm-gc/Makefile.am
parentbcbf05db35f05f44df44c260c63ce7eda1ea1074 (diff)
downloadgcc-c1513f4f05dc3f73c3a1ad391d9c6f5b9f877654.tar.gz
boehm-gc/ChangeLog:
2005-06-16 Paolo Bonzini <bonzini@gnu.org> * boehm-gc/configure.ac: New name of configure.in. Remove useless multilib stuff. Change uses of INCLUDES and CXXINCLUDES to AM_CPPFLAGS. * boehm-gc/configure.in: New name of configure.in. * boehm-gc/Makefile.am: Update for automake 1.8.5. * boehm-gc/acinclude.m4: Include ../config/acx.m4. * boehm-gc/aclocal.m4: Regenerate. * boehm-gc/configure: Regenerate. contrib/ChangeLog: 2004-06-16 Paolo Bonzini <bonzini@gnu.org> * gcc_update (boehm-gc/configure): Depend on boehm-gc/configure.ac instead of boehm-gc/configure.in gcc/ChangeLog: 2004-06-16 Paolo Bonzini <bonzini@gnu.org> * doc/install.texi: boehm-gc now uses automake 1.8.5. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@83227 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/Makefile.am')
-rw-r--r--boehm-gc/Makefile.am58
1 files changed, 4 insertions, 54 deletions
diff --git a/boehm-gc/Makefile.am b/boehm-gc/Makefile.am
index 286a34c5a78..502cb232641 100644
--- a/boehm-gc/Makefile.am
+++ b/boehm-gc/Makefile.am
@@ -4,20 +4,10 @@
## files that should be in the distribution are not mentioned in this
## Makefile.am.
-target_noncanonical=@target_noncanonical@
-
-AUTOMAKE_OPTIONS = cygnus
+AUTOMAKE_OPTIONS = cygnus subdir-objects
SUBDIRS = include
-# Multilib support variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
noinst_LTLIBRARIES = libgcjgc.la libgcjgc_convenience.la
if POWERPC_DARWIN
@@ -35,15 +25,13 @@ backgraph.c win32_threads.c \
pthread_support.c pthread_stop_world.c darwin_stop_world.c \
$(asm_libgc_sources)
-EXTRA_GC_SOURCES = alpha_mach_dep.S \
+EXTRA_DIST = alpha_mach_dep.S \
mips_sgi_mach_dep.s mips_ultrix_mach_dep.s powerpc_darwin_mach_dep.s \
rs6000_mach_dep.s sparc_mach_dep.S sparc_netbsd_mach_dep.s \
sparc_sunos4_mach_dep.s ia64_save_regs_in_stack.s
libgcjgc_la_SOURCES = $(GC_SOURCES)
libgcjgc_convenience_la_SOURCES = $(GC_SOURCES)
-EXTRA_libgcjgc_la_SOURCES = $(EXTRA_GC_SOURCES)
-EXTRA_libgcjgc_convenience_la_SOURCES = $(EXTRA_GC_SOURCES)
# Include THREADLIBS here to ensure that the correct versions of
# linuxthread semaphore functions get linked:
@@ -58,25 +46,12 @@ AM_CXXFLAGS = @GC_CFLAGS@
AM_CFLAGS = @GC_CFLAGS@
check_PROGRAMS = gctest
-# The following hack produces a warning from automake, but we need it in order
-# to build a file from a subdirectory. FIXME.
-test.o: tests/test.c
- $(COMPILE) -c $(srcdir)/tests/test.c
-# Using $< in the above seems to fail with the HP/UX on Itanium make.
-
-gctest_OBJECTS = test.o
+gctest_SOURCES = tests/test.c
gctest_LDADD = ./libgcjgc.la $(THREADLIBS) $(EXTRA_TEST_LIBS)
gctest_LDFLAGS = -shared-libgcc
TESTS_ENVIRONMENT = LD_LIBRARY_PATH=../../$(MULTIBUILDTOP)gcc
TESTS = gctest
-## FIXME: relies on internal code generated by automake.
-all_objs = @addobjs@ $(libgcjgc_la_OBJECTS)
-$(all_objs) : include/private/gcconfig.h include/private/gc_priv.h \
-include/private/gc_hdrs.h include/gc.h include/gc_gcj.h \
-include/gc_pthread_redirects.h include/gc_config_macros.h \
-include/gc_mark.h @addincludes@
-
## FIXME: we shouldn't have to do this, but automake forces us to.
.s.lo:
## We use -Wp,-P to strip #line directives. Irix `as' chokes on
@@ -85,8 +60,7 @@ include/gc_mark.h @addincludes@
## We have our own definition of LTCOMPILE because we want to use our
## CFLAGS, not those passed in from the top level make.
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) \
- $(AM_CPPFLAGS) $(CPPFLAGS) \
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(MY_CFLAGS) $(GC_CFLAGS)
LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
@@ -133,28 +107,4 @@ AM_MAKEFLAGS = \
CONFIG_STATUS_DEPENDENCIES = $(srcdir)/configure.host
-# Multilib support.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
- maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
- : $(MAKE) ; exec $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
- $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
- $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
- $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
- $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
- $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
-
MAKEOVERRIDES=