summaryrefslogtreecommitdiff
path: root/boehm-gc/Makefile.am
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2002-03-17 00:35:21 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2002-03-17 00:35:21 +0000
commit9d0a2dd5939dee43a9b729fc9e278fa4b07822d0 (patch)
tree4a1b8a8dce551af5a22e374180cfc27a991b3dfc /boehm-gc/Makefile.am
parentc7a20c1fe1ab884b0b4497a9f8f32a6a6a264e44 (diff)
downloadgcc-9d0a2dd5939dee43a9b729fc9e278fa4b07822d0.tar.gz
zlib:
* Makefile.am: Make target library a convenience library. * Makefile.in: Rebuilt. libffi: * Makefile.am: libfficonvenience -> libffi_convenience. * Makefile.in: Rebuilt. boehm-gc: * Makefile.am: Make a convenience library. * Makefile.in: Rebuilt. libjava: Build a single libgcj.so, without separate gc and zlib libraries. * configure.in: Use convenience libraries for boehm-gc and zlib. Set SYS_ZLIBS if system zlib is used. * configure: Rebuilt. * Makefile.am: Use boehm-gc and zlib convenience libraries. * Makefile.in: Rebuilt. * libtool-version: Increment .so version number. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@50900 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/Makefile.am')
-rw-r--r--boehm-gc/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/boehm-gc/Makefile.am b/boehm-gc/Makefile.am
index 12a072dcdd4..48526556dad 100644
--- a/boehm-gc/Makefile.am
+++ b/boehm-gc/Makefile.am
@@ -25,25 +25,34 @@ toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
endif
-toolexeclib_LTLIBRARIES = $(target_all)
-EXTRA_LTLIBRARIES = libgcjgc.la
-libgcjgc_la_SOURCES = allchblk.c alloc.c blacklst.c checksums.c dbg_mlc.c \
+toolexeclib_LTLIBRARIES = libgcjgc.la
+noinst_LTLIBRARIES = libgcjgc_convenience.la
+
+GC_SOURCES = allchblk.c alloc.c blacklst.c checksums.c dbg_mlc.c \
dyn_load.c finalize.c gc_dlopen.c gcj_mlc.c headers.c irix_threads.c \
linux_threads.c malloc.c mallocx.c mark.c mark_rts.c misc.c new_hblk.c \
obj_map.c os_dep.c pcr_interface.c ptr_chck.c real_malloc.c reclaim.c \
solaris_pthreads.c solaris_threads.c specific.c stubborn.c typd_mlc.c \
backgraph.c win32_threads.c
+EXTRA_GC_SOURCES = alpha_mach_dep.s \
+mips_sgi_mach_dep.S mips_ultrix_mach_dep.s powerpc_macosx_mach_dep.s \
+rs6000_mach_dep.s sparc_mach_dep.S sparc_netbsd_mach_dep.s \
+sparc_sunos4_mach_dep.s ia64_save_regs_in_stack.s
+
+libgcjgc_la_SOURCES = $(GC_SOURCES)
+libgcjgc_convenience_la_SOURCES = $(GC_SOURCES)
+EXTRA_libgcjgc_la_SOURCES = $(EXTRA_GC_SOURCES)
+EXTRA_libgcjgc_convenience_la_SOURCES = $(EXTRA_GC_SOURCES)
+
# Include THREADLIBS here to ensure that the correct versions of
# linuxthread semaphore functions get linked:
libgcjgc_la_LIBADD = @addobjs@ $(THREADLIBS)
libgcjgc_la_DEPENDENCIES = @addobjs@
libgcjgc_la_LDFLAGS = -version-info 1:1:0 -rpath $(toolexeclibdir)
-EXTRA_libgcjgc_la_SOURCES = alpha_mach_dep.s \
-mips_sgi_mach_dep.S mips_ultrix_mach_dep.s powerpc_macosx_mach_dep.s \
-rs6000_mach_dep.s sparc_mach_dep.S sparc_netbsd_mach_dep.s \
-sparc_sunos4_mach_dep.s ia64_save_regs_in_stack.s
+libgcjgc_convenience_la_LIBADD = @addobjs@
+libgcjgc_convenience_la_DEPENDENCIES = @addobjs@
AM_CXXFLAGS = @GC_CFLAGS@
AM_CFLAGS = @GC_CFLAGS@