summaryrefslogtreecommitdiff
path: root/boehm-gc/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-06-21 13:03:47 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>1999-06-21 13:03:47 +0000
commitc34aeb9d18d45fd59b972838c9dbd41b6d434d34 (patch)
tree3eb065174a652092763e1549b98f6df22f1939c4 /boehm-gc/Makefile.am
parent5c4e04548894fcf7ec535bfa4407dbe610a7a6cf (diff)
downloadgcc-c34aeb9d18d45fd59b972838c9dbd41b6d434d34.tar.gz
* Makefile.in: Rebuilt.
* Makefile.am (toolexeclibdir): Define as libdir when appropriate. * configure: Rebuilt. * configure.in (USE_LIBDIR): New conditional. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@27667 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/Makefile.am')
-rw-r--r--boehm-gc/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/boehm-gc/Makefile.am b/boehm-gc/Makefile.am
index cd18abbeed2..48d5211eec6 100644
--- a/boehm-gc/Makefile.am
+++ b/boehm-gc/Makefile.am
@@ -14,8 +14,14 @@ MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
+## Install a library built with a cross compiler in tooldir, not
+## libdir.
+if USE_LIBDIR
+toolexeclibdir = $(libdir)
+else
toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+endif
toolexeclib_LTLIBRARIES = $(target_all)
EXTRA_LTLIBRARIES = libgcjgc.la