summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorRainer Orth <ro@TechFak.Uni-Bielefeld.DE>2007-07-02 14:56:58 +0000
committerRainer Orth <ro@gcc.gnu.org>2007-07-02 14:56:58 +0000
commit28e2ff77f2e167471ebff7b8457f3b1f3a3f910e (patch)
treec070d60e2b0ce4ddf54fb60be91b6eb4e926d8f5 /boehm-gc/configure.ac
parenta3b7729c66c3defccbed94534a7af6cd85d70efa (diff)
downloadgcc-28e2ff77f2e167471ebff7b8457f3b1f3a3f910e.tar.gz
re PR boehm-gc/21940 (boehm-gc gctest fails on Solaris 10/x86)
PR boehm-gc/21940 PR boehm-gc/21942 * configure.ac (GC_SOLARIS_THREADS): Don't define on *-*-solaris*. Use alternate thread library in /usr/lib/lwp. * configure: Regenerate. * dyn_load.c: Use GC_SOLARIS_PTHREADS. * include/gc_config_macros.h (GC_SOLARIS_THREADS): Don't define. * include/private/gcconfig.h: Handle 64-bit Solaris 2/x86. (GC_SOLARIS_THREADS): Don't define. * include/private/solaris_threads.h: Remove. * pthread_support.c (GC_thr_init) [GC_SOLARIS_PTHREADS]: Determine GC_nprocs via sysconf(). * Makefile.am (libgcjgc_la_SOURCES): Remove solaris_pthreads.c and solaris_threads.c. (gctest_LDADD): Use THREADLIBS instead of THREADDLLIBS. * Makefile.in: Regenerate. * solaris_pthreads.c: Remove. * solaris_threads.c: Remove. From-SVN: r126211
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 5c26b8454fc..29331e607d6 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -173,8 +173,12 @@ case "$THREADS" in
THREADLIBS=-pthread
;;
*-*-solaris*)
- AC_DEFINE(GC_SOLARIS_THREADS,1,[support for Solaris (thr_) threads])
AC_DEFINE(GC_SOLARIS_PTHREADS,1,[support for Solaris pthreads])
+ # Need to use alternate thread library, otherwise gctest hangs
+ # on Solaris 8.
+ multi_os_directory=`$CC -print-multi-os-directory`
+ THREADLIBS="-L/usr/lib/lwp/$multi_os_directory \
+ -R/usr/lib/lwp/$multi_os_directory -lpthread -lthread -lrt"
;;
*-*-irix*)
AC_DEFINE(GC_IRIX_THREADS,1,[support for Irix pthreads])