summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2007-05-20 10:34:05 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2007-05-20 10:34:05 +0000
commit8077c4b6acd251ba005ca8d67bf735f1793f69a0 (patch)
tree3ebc8443613c9af9453483fbd67724d06ef1f6ec /boehm-gc/configure.ac
parent488520a7cf03b3117d4f35a39cffb5dc9ad99cef (diff)
downloadgcc-8077c4b6acd251ba005ca8d67bf735f1793f69a0.tar.gz
2007-05-20 Andreas Tobler <a.tobler@schweiz.org>
* configure.ac: Introduce extra_ldflags_libgc. Use it for Darwin. * configure: Regenerate. * Makefile.am (libgc_la_LDFLAGS): Use extra_ldflags_libgc. * Makefile.in: Regenerate. * include/Makefile.in: Regenerate. * include/private/gcconfig.h: Enable MPROTECT_VDB for all Darwin targets. Remove comments. Prepare ppc64 support for Darwin. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@124870 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index d4dd16b9e06..5c26b8454fc 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -300,6 +300,14 @@ case "$host" in
;;
esac
+# extra LD Flags which are required for targets
+case "${host}" in
+ *-*-darwin*)
+ extra_ldflags_libgc=-Wl,-single_module
+ ;;
+esac
+AC_SUBST(extra_ldflags_libgc)
+
AC_SUBST(EXTRA_TEST_LIBS)
target_all=libgcjgc.la