summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2006-09-18 18:45:08 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2006-09-18 18:45:08 +0000
commitf5ba0cf6571d7aeaef1325e10d05b0ddce6afcad (patch)
tree666cdb5c8b90249ec72621c86394c11ef6b41897 /boehm-gc/configure.ac
parent736ed0275139b08065235f71cbbe0216db92d2f2 (diff)
downloadgcc-f5ba0cf6571d7aeaef1325e10d05b0ddce6afcad.tar.gz
2006-06-07 Petr Salinger <Petr.Salinger@seznam.cz>
* configure.ac: add support for GNU/kFreeBSD, accepted by upstream for gc 6.8. * dyn_load.c: Likewise. * include/gc.h: Likewise. * private/gcconfig.h: Likewise. * configure: Regenerate. * include/gc_config.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@117033 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 807b7a1a758..45937dcf9b9 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -155,6 +155,17 @@ case "$THREADS" in
*-*-hpux10*)
AC_MSG_WARN("Only HP-UX 11 POSIX threads are supported.")
;;
+ *-*-kfreebsd*-gnu)
+ AC_DEFINE(GC_FREEBSD_THREADS)
+ INCLUDES="$INCLUDES -pthread"
+ THREADDLLIBS=-pthread
+ AC_DEFINE(_REENTRANT)
+ if test "${enable_parallel_mark}" = yes; then
+ AC_DEFINE(PARALLEL_MARK)
+ fi
+ AC_DEFINE(THREAD_LOCAL_ALLOC)
+ AC_DEFINE(USE_COMPILER_TLS, 1,[use tls for boehm])
+ ;;
*-*-freebsd*)
AC_MSG_WARN("FreeBSD does not yet fully support threads with Boehm GC.")
AC_DEFINE(GC_FREEBSD_THREADS,1,[support FreeBSD threads])