summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-16 18:58:05 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-16 18:58:05 +0000
commit9575535e25170210488503f42fa4f7767fccaf2e (patch)
tree71da7587dc11e752d9d8bfd1e550dd73b3bf2671 /boehm-gc/configure.ac
parent09c6aad02e8dcf09e0dacfe16766dbcd6dfc00a1 (diff)
downloadgcc-9575535e25170210488503f42fa4f7767fccaf2e.tar.gz
2004-08-16 Nathanael Nerode <neroden@gcc.gnu.org>
* aclocal.m4: Remove obsolete construct for old automake. * acinclude.m4: Regenerate with aclocal 1.9.1. * configure.ac: Remove duplicate AC_WITH calls. Replace AC_CANONICAL_SYSTEM with AC_CANONICAL_HOST, AC_CANONICAL_TARGET. Replace _GCC_TOPLEV_NONCANONICAL calls with ACX_NONCANONICAL_TARGET. Remove now-redundant subst of target_noncanonical. Remove now-gratuitous m4 quoting around $. Replace AM_PROG_LIBTOOL with AC_PROG_LIBTOOL and remove second, redundant AC_PROG_LIBTOOL. Use slightly more modern form of AC_INIT. * configure: Rebuild with autoconf 2.59. * Makefile.in, include/Makefile.in: Rebuild with automake 1.9.1. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@86071 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.ac')
-rw-r--r--boehm-gc/configure.ac37
1 files changed, 13 insertions, 24 deletions
diff --git a/boehm-gc/configure.ac b/boehm-gc/configure.ac
index 0137ff6519f..d14b48b4a86 100644
--- a/boehm-gc/configure.ac
+++ b/boehm-gc/configure.ac
@@ -16,8 +16,8 @@
dnl Process this file with autoconf to produce configure.
AC_PREREQ(2.59)
-AC_INIT(gcj_mlc.c)
-
+AC_INIT
+AC_CONFIG_SRCDIR(gcj_mlc.c)
# This works around the fact that libtool configuration may change LD
# for this particular configuration, but some shells, instead of
# keeping the changes in LD private, export them just because LD is
@@ -26,12 +26,11 @@ ORIGINAL_LD_FOR_MULTILIBS=$LD
AM_ENABLE_MULTILIB(, ..)
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
+AC_CANONICAL_TARGET
# Get the 'noncanonical' system names.
-_GCC_TOPLEV_NONCANONICAL_BUILD
-_GCC_TOPLEV_NONCANONICAL_HOST
-_GCC_TOPLEV_NONCANONICAL_TARGET
+ACX_NONCANONICAL_TARGET
# This works around an automake problem.
mkinstalldirs="`cd $ac_aux_dir && ${PWDCMD-pwd}`/mkinstalldirs"
@@ -72,26 +71,26 @@ AC_PROG_INSTALL
AM_MAINTAINER_MODE
-. [$]{srcdir}/configure.host
+. ${srcdir}/configure.host
-case [$]{gc_basedir} in
-/* | [A-Za-z]:[/\\]*) gc_flagbasedir=[$]{gc_basedir} ;;
-*) gc_flagbasedir='[$](top_builddir)/'[$]{gc_basedir} ;;
+case ${gc_basedir} in
+/* | [A-Za-z]:[/\\]*) gc_flagbasedir=${gc_basedir} ;;
+*) gc_flagbasedir='$(top_builddir)/'${gc_basedir} ;;
esac
-gc_cflags="[$]{gc_cflags} -Iinclude -I"'[$](top_builddir)'"/./targ-include -I[$]{gc_flagbasedir}/libc/include"
+gc_cflags="${gc_cflags} -Iinclude -I"'$(top_builddir)'"/./targ-include -I${gc_flagbasedir}/libc/include"
case "${host}" in
*-*-cygwin32*)
- gc_cflags="[$]{gc_cflags} -I[$]{gc_flagbasedir}/../winsup/include"
+ gc_cflags="${gc_cflags} -I${gc_flagbasedir}/../winsup/include"
;;
esac
-dnl gc_cflags="[$]{gc_cflags} -fno-builtin"
+dnl gc_cflags="${gc_cflags} -fno-builtin"
GC_CFLAGS=${gc_cflags}
AC_SUBST(GC_CFLAGS)
-AM_PROG_LIBTOOL
+AC_PROG_LIBTOOL
dnl We use these options to decide which functions to include.
AC_ARG_WITH(target-subdir,
@@ -242,7 +241,6 @@ AC_SUBST(EXTRA_TEST_LIBS)
target_all=libgcjgc.la
AC_SUBST(target_all)
-AC_SUBST(target_noncanonical)
dnl If the target is an eCos system, use the appropriate eCos
dnl I/O routines.
@@ -357,8 +355,6 @@ AC_SUBST(addincludes)
AC_SUBST(addlibs)
AC_SUBST(addtests)
-AC_PROG_LIBTOOL
-
#
# Check for AViiON Machines running DGUX
#
@@ -381,13 +377,6 @@ if test $ac_is_dgux = yes; then
AC_SUBST(CXXFLAGS)
fi
-dnl We use these options to decide which functions to include.
-AC_ARG_WITH(target-subdir,
-[ --with-target-subdir=SUBDIR
- configuring with a cross compiler])
-AC_ARG_WITH(cross-host,
-[ --with-cross-host=HOST configuring with a cross compiler])
-
dnl As of 4.13a2, the collector will not properly work on Solaris when
dnl built with gcc and -O. So we remove -O in the appropriate case.
dnl