summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-26 21:39:45 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-26 21:39:45 +0000
commit3bade5c315d232176eb83cdb7baeb16bd084a727 (patch)
tree5fea6da73931f5cb669581538953a9db9518e83c /boehm-gc/configure.in
parentfefedfd10f79e23ea1904e93f0321d6201db7c08 (diff)
downloadgcc-3bade5c315d232176eb83cdb7baeb16bd084a727.tar.gz
* acinclude.m4: Remove GC_CONFIGURE macro; move contents
to configure.in. * aclocal.m4: Regenerate. * configure.in: Receive contents of GC_CONFIGURE macro. * configure: Regenerate. (Makefile.in and include/Makefile.in just got timestamp updates) git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@78523 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in46
1 files changed, 45 insertions, 1 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index e58ca15424c..0ab5a84a379 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -69,7 +69,51 @@ _GCC_TOPLEV_NONCANONICAL_TARGET
mkinstalldirs="`cd $ac_aux_dir && ${PWDCMD-pwd}`/mkinstalldirs"
AC_SUBST(mkinstalldirs)
-GC_CONFIGURE(.)
+AM_INIT_AUTOMAKE(gc, 6.1a1, no-define)
+
+# The autoconf 2.5x version of the no-executables hack.
+sinclude(../config/no-executables.m4)
+GCC_NO_EXECUTABLES
+
+# Yak. We must force CC and CXX to /not/ be precious variables; otherwise
+# the wrong, non-multilib-adjusted value will be used in multilibs.
+# As a side effect, we have to subst CFLAGS and CXXFLAGS ourselves.
+
+m4_rename([_AC_ARG_VAR_PRECIOUS],[real_PRECIOUS])
+m4_define([_AC_ARG_VAR_PRECIOUS],[])
+AC_PROG_CC
+AC_PROG_CXX
+m4_rename([real_PRECIOUS],[_AC_ARG_VAR_PRECIOUS])
+
+AC_SUBST(CFLAGS)
+AC_SUBST(CXXFLAGS)
+
+AC_CHECK_TOOL(AS, as)
+AC_CHECK_TOOL(AR, ar)
+AC_CHECK_TOOL(RANLIB, ranlib, :)
+
+AC_PROG_INSTALL
+
+AM_MAINTAINER_MODE
+
+. [$]{srcdir}/configure.host
+
+case [$]{gc_basedir} in
+/* | [A-Za-z]:[/\\]*) gc_flagbasedir=[$]{gc_basedir} ;;
+*) gc_flagbasedir='[$](top_builddir)/'[$]{gc_basedir} ;;
+esac
+
+gc_cflags="[$]{gc_cflags} -I"'[$](top_builddir)'"/./targ-include -I[$]{gc_flagbasedir}/libc/include"
+case "${host}" in
+ *-*-cygwin32*)
+ gc_cflags="[$]{gc_cflags} -I[$]{gc_flagbasedir}/../winsup/include"
+ ;;
+esac
+
+dnl gc_cflags="[$]{gc_cflags} -fno-builtin"
+
+GC_CFLAGS=${gc_cflags}
+AC_SUBST(GC_CFLAGS)
AM_PROG_LIBTOOL