summaryrefslogtreecommitdiff
path: root/boehm-gc/configure.in
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2002-02-12 04:37:57 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2002-02-12 04:37:57 +0000
commit0cc01484c3f8c9ec4fec760501aec318bc199adf (patch)
treecef3197531d988920cbff060bdc10742baf06d01 /boehm-gc/configure.in
parentb6c37935d39c0aadd3d6eefb9e09c455c6cbd0a5 (diff)
downloadgcc-0cc01484c3f8c9ec4fec760501aec318bc199adf.tar.gz
Imported GC 6.1 Alpha 3. Finally.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@49698 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'boehm-gc/configure.in')
-rw-r--r--boehm-gc/configure.in25
1 files changed, 17 insertions, 8 deletions
diff --git a/boehm-gc/configure.in b/boehm-gc/configure.in
index 661d0189725..d22516c2f00 100644
--- a/boehm-gc/configure.in
+++ b/boehm-gc/configure.in
@@ -90,8 +90,7 @@ case "$THREADS" in
THREADLIBS="-lpthread -lrt"
;;
*-*-freebsd*)
- AC_MSG_WARN("Threaded GC is prone to deadlock before FreeBSD 4.5.")
- AC_MSG_WARN("Related symptom is pthread_join returns spurious EINTR.")
+ AC_MSG_WARN("FreeBSD does not yet fully support threads with Boehm GC.")
AC_DEFINE(GC_FREEBSD_THREADS)
INCLUDES="$INCLUDES -pthread"
THREADLIBS=-pthread
@@ -155,8 +154,13 @@ AC_SUBST(CXXINCLUDES)
machdep=
case "$host" in
- alpha*-*-*)
- machdep="alpha_mach_dep.lo"
+# alpha_mach_dep.s assumes that pointers are not saved in fp registers.
+# Gcc on a 21264 can spill pointers to fp registers. Oops.
+# alpha*-*-*)
+# machdep="alpha_mach_dep.lo"
+# ;;
+ i?86-*-solaris2.[[89]]*)
+ AC_DEFINE(SOLARIS25_PROC_VDB_BUG_FIXED)
;;
alpha-*-openbsd*)
if test x"${ac_cv_lib_dl_dlopen}" != xyes ; then
@@ -164,9 +168,6 @@ case "$host" in
AM_DISABLE_SHARED
fi
;;
- i?86-*-solaris2.[[89]]*)
- AC_DEFINE(SOLARIS25_PROC_VDB_BUG_FIXED)
- ;;
mipstx39-*-elf*)
machdep="mips_ultrix_mach_dep.lo"
AC_DEFINE(STACKBASE, __stackbase)
@@ -180,9 +181,13 @@ case "$host" in
AC_DEFINE(NO_EXECUTE_PERMISSION)
;;
sparc-sun-solaris2.3*)
+ machdep="sparc_mach_dep.lo"
AC_DEFINE(SUNOS53_SHARED_LIB)
;;
- ia64-*-hpux*)
+ sparc-sun-solaris2.*)
+ machdep="sparc_mach_dep.lo"
+ ;;
+ ia64-*-*)
machdep="mach_dep.lo ia64_save_regs_in_stack.lo"
;;
esac
@@ -243,7 +248,11 @@ AC_ARG_ENABLE(full-debug,
AC_DEFINE(KEEP_BACK_PTRS)
AC_DEFINE(DBG_HDRS_ALL)
case $host in
+ ia64-*-linux* )
+ AC_DEFINE(MAKE_BACK_GRAPH)
+ ;;
x86-*-linux* | i586-*-linux* | i686-*-linux* )
+ AC_DEFINE(MAKE_BACK_GRAPH)
AC_MSG_WARN("Client must not use -fomit-frame-pointer.")
AC_DEFINE(SAVE_CALL_COUNT, 8)
;;