summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-02 18:06:19 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-02 18:06:19 +0000
commit7deb2d7096f0ee61d7205b09cddc2bdf83942196 (patch)
treed2d588b29b375f145ddbfb0843a4f197456c6e22 /configure.ac
parent35974859d13c92ab9ab4c8d5f21feafb998e3e13 (diff)
downloadgcc-7deb2d7096f0ee61d7205b09cddc2bdf83942196.tar.gz
./:
* configure.ac: Always set default for poststage1_ldflags to -static-libstdc++ -static-libgcc. gcc/: * doc/install.texi (Configuration): Update default for --with-boot-ldflags. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@167382 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 65c0a74cda9..289416f79f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1561,10 +1561,10 @@ AC_ARG_WITH(boot-ldflags,
poststage1_ldflags=$withval
fi],
[poststage1_ldflags=
- # With --enable-build-with-cxx, default to linking libstdc++ and
- # libgcc statically. But if the user explicitly specified the
- # libraries to use, trust that they are doing what they want.
- if test "$ENABLE_BUILD_WITH_CXX" = "yes" -a "$poststage1_libs" = ""; then
+ # In stages 2 and 3, default to linking libstdc++ and libgcc
+ # statically. But if the user explicitly specified the libraries to
+ # use, trust that they are doing what they want.
+ if test "$poststage1_libs" = ""; then
poststage1_ldflags="-static-libstdc++ -static-libgcc"
fi])
AC_SUBST(poststage1_ldflags)