summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Orth <ro@CeBiTec.Uni-Bielefeld.DE>2011-03-21 12:26:30 +0000
committerRainer Orth <ro@gcc.gnu.org>2011-03-21 12:26:30 +0000
commit474ee90816f960259d99c5deeeac54a559bd4f34 (patch)
tree5dbbe6e9b187f5d7b351d9c462be4348aaa35075 /configure.ac
parentbf382f5fe4e20e57acee67d703de5a966fef9778 (diff)
downloadgcc-474ee90816f960259d99c5deeeac54a559bd4f34.tar.gz
re PR bootstrap/48120 (libpwl test must use g++)
PR bootstrap/48120: * configure.ac (pwllib): Use LIBS instead of LDFLAGS. Add -lstdc++ -lm to LIBS. * configure: Regenerate. From-SVN: r171225
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6b17b68dc0a..58bbe448e53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1677,10 +1677,10 @@ fi
if test "x$with_ppl" != xno; then
if test "x$pwllib" = x; then
- saved_LDFLAGS="$LDFLAGS"
- LDFLAGS="$LDFLAGS $ppllibs"
- AC_CHECK_LIB(pwl,PWL_handle_timeout,[pwllib="-lpwl"])
- LDFLAGS="$saved_LDFLAGS"
+ saved_LIBS="$LIBS"
+ LIBS="$LIBS $ppllibs -lstdc++ -lm"
+ AC_CHECK_LIB(pwl, PWL_handle_timeout, [pwllib="-lpwl"])
+ LIBS="$saved_LIBS"
fi
ppllibs="$ppllibs -lppl_c -lppl $pwllib -lgmpxx"