summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2016-04-26 08:10:43 +0200
committerJakub Jelinek <jakub@gcc.gnu.org>2016-04-26 08:10:43 +0200
commit7db11a5a3233b5181d38957a426f88da1d791478 (patch)
tree3ae8d8abe5093326ad45e3a9961718c34e91ccd9 /configure.ac
parent513d5d7f553f880388845950cd771edda6e769fd (diff)
downloadgcc-7db11a5a3233b5181d38957a426f88da1d791478.tar.gz
re PR bootstrap/70704 (AIX bootstrap comparison failure)
PR bootstrap/70704 * configure.ac (--enable-stage1-checking): For --disable-checking or implicit --enable-checking, make sure extra flag matches in between stage1 and later checking. * configure: Regenerated. gcc/ * configure.ac (--enable-checking): Document extra flag, for non-release builds default to --enable-checking=yes,extra. If misc checking and extra checking, define CHECKING_P to 2 instead of 1. * common.opt (fchecking=): Add. * doc/invoke.texi (-fchecking=): Document. * doc/install.texi: Document --enable-checking changes. * configure: Regenerated. * config.in: Regenerated. gcc/cp/ * pt.c (build_non_dependent_expr): Use flag_checking > 1 instead of just flag_checking. From-SVN: r235430
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 74bf58aad93..1652182fd14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3530,16 +3530,17 @@ AC_ARG_ENABLE(stage1-checking,
# For --disable-checking or implicit --enable-checking=release, avoid
# setting --enable-checking=gc in the default stage1 checking for LTO
# bootstraps. See PR62077.
- stage1_checking=--enable-checking=release,misc,gimple,rtlflag,tree,types
case $BUILD_CONFIG in
*lto*)
- if test "x$enable_checking" = x && \
- test -d ${srcdir}/gcc && \
- test x"`cat ${srcdir}/gcc/DEV-PHASE`" = xexperimental; then
- stage1_checking=--enable-checking=yes,types
- fi;;
- *) stage1_checking=--enable-checking=yes,types;;
+ stage1_checking=--enable-checking=release,misc,gimple,rtlflag,tree,types;;
+ *)
+ stage1_checking=--enable-checking=yes,types;;
esac
+ if test "x$enable_checking" = x && \
+ test -d ${srcdir}/gcc && \
+ test x"`cat ${srcdir}/gcc/DEV-PHASE`" = xexperimental; then
+ stage1_checking=yes,types,extra
+ fi
else
stage1_checking=--enable-checking=$enable_checking,types
fi])