summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2010-10-02 14:52:07 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2010-10-02 14:52:07 +0000
commit372a3f1ebc6314fc09d12ea4dd2f10cb65ea1d43 (patch)
tree2bc93cf6744bf10457800aad14d751389a4dc261 /configure.ac
parent6e7f08addb117df3184e6756f25f2024eff7f003 (diff)
downloadgcc-372a3f1ebc6314fc09d12ea4dd2f10cb65ea1d43.tar.gz
Allow to pass separate configure arguments for build, host and target.
/: PR bootstrap/45326 PR bootstrap/45174 * configure.ac: Honor initial values of $build_configargs, $host_configargs, $target_configargs. Mark the precious, so environment settings get recorded. * configure: Regenerate. gcc/: * doc/install.texi (Configuration): Document build_configargs, host_configargs, target_configargs. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@164904 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6ef9df67261..5f80aa963fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2969,10 +2969,18 @@ if test "$silent" = yes; then
fi
baseargs="$baseargs --disable-option-checking"
+# Record and document user additions to sub configure arguments.
+AC_ARG_VAR([build_configargs],
+ [additional configure arguments for build directories])
+AC_ARG_VAR([host_configargs],
+ [additional configure arguments for host directories])
+AC_ARG_VAR([target_configargs],
+ [additional configure arguments for target directories])
+
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor
# desired.
-build_configargs="--cache-file=../config.cache ${baseargs}"
+build_configargs="$build_configargs --cache-file=../config.cache ${baseargs}"
# For host modules, accept cache file option, or specification as blank.
case "${cache_file}" in
@@ -2986,9 +2994,9 @@ esac
# Host dirs don't like to share a cache file either, horribly enough.
# This seems to be due to autoconf 2.5x stupidity.
-host_configargs="--cache-file=./config.cache ${extra_host_args} ${baseargs}"
+host_configargs="$host_configargs --cache-file=./config.cache ${extra_host_args} ${baseargs}"
-target_configargs=${baseargs}
+target_configargs="$target_configargs ${baseargs}"
# Passing a --with-cross-host argument lets the target libraries know
# whether they are being built with a cross-compiler or being built