summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2007-05-30 13:32:34 +0000
committerjakub <jakub@138bc75d-0d04-0410-961f-82ee72b054a4>2007-05-30 13:32:34 +0000
commit505abe0cdd05009779ed51178a19dfc968ffde22 (patch)
treeef9039e3f5a8e3776c2f155d9e8ab48861bd97db /configure.ac
parent4122c2d468cf0f8912ac09c67c4aec14347bfda1 (diff)
downloadgcc-505abe0cdd05009779ed51178a19dfc968ffde22.tar.gz
PR bootstrap/29382
* configure.in: Don't use -fkeep-inline-functions for GCC < 3.3.1. * configure: Rebuilt. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@125182 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9c38fadfd94..6309b6e033d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2566,7 +2566,13 @@ if test "$GCC" = yes; then
# Pass -fkeep-inline-functions for stage 1 if the GCC version supports it.
CFLAGS="$CFLAGS -fkeep-inline-functions"
AC_MSG_CHECKING([whether -fkeep-inline-functions is supported])
- AC_TRY_COMPILE(,,
+ AC_TRY_COMPILE([
+#if (__GNUC__ < 3) \
+ || (__GNUC__ == 3 && (__GNUC_MINOR__ < 3 \
+ || (__GNUC_MINOR__ == 3 && __GNUC_PATCHLEVEL__ < 1)))
+#error http://gcc.gnu.org/PR29382
+#endif
+ ],,
[AC_MSG_RESULT([yes]); stage1_cflags="$stage1_cflags -fkeep-inline-functions"],
[AC_MSG_RESULT([no])])