summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2010-01-02 14:13:37 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2010-01-02 14:13:37 +0000
commit1a4f45ec561061175f65785bc33f8a4aa0007c0e (patch)
treed3cf010a771c7989f27711166a6e0dcd842e9115 /configure.ac
parentbfc463e4662ab7c4dcf6e85de5eaaa5e937781d9 (diff)
downloadgcc-1a4f45ec561061175f65785bc33f8a4aa0007c0e.tar.gz
2010-01-02 Richard Guenther <rguenther@suse.de>
PR lto/41529 * configure.ac: Include config/elf.m4. Disable LTO if not builting for an elf target. * configure: Regenerate. config/ * elf.m4: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@155565 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dbc1565ec2a..9a7123227cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,7 @@
m4_include(config/acx.m4)
m4_include(config/override.m4)
m4_include(config/proginstall.m4)
+m4_include(config/elf.m4)
AC_INIT(move-if-change)
AC_PREREQ(2.64)
@@ -1601,6 +1602,16 @@ AC_ARG_ENABLE(lto,
enable_lto=$enableval,
enable_lto=yes; default_enable_lto=yes)
+ACX_ELF_TARGET_IFELSE([],
+if test x"$default_enable_lto" = x"yes" ; then
+ enable_lto=no
+else
+ if test x"$enable_lto" = x"yes"; then
+ AC_MSG_ERROR([LTO support requires an ELF target.])
+ fi
+fi
+default_enable_lto=no)
+
if test x"$enable_lto" = x"yes" ; then
# Make sure that libelf.h and gelf.h are available.
AC_ARG_WITH(libelf, [ --with-libelf=PATH Specify prefix directory for the installed libelf package