summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2015-10-20 16:29:28 +0000
committerhjl <hjl@138bc75d-0d04-0410-961f-82ee72b054a4>2015-10-20 16:29:28 +0000
commitafb6adb98a5c7b44bc2d12a83e90e6e4bd250777 (patch)
treefdf0d01594db7c6329d5e5e4c6dfcc2ececed0e2 /configure.ac
parent033b4ff6450022b7bedcb841b4b5d9f2f7f753c0 (diff)
downloadgcc-afb6adb98a5c7b44bc2d12a83e90e6e4bd250777.tar.gz
Add --enable-compressed-debug-sections={all,gas,gold,ld}
This patch removes the gas configure option: --enable-compressed-debug-sections and adds a toplevel configure option: --enable-compressed-debug-sections={all,gas,gold,ld} to enable compressed debug sections for gas, gold or ld by default. At the moment, this configure option is ignored by gold and ld. For x86 Linux targets, default to compressing debug sections in gas. Sync with binutils-gdb: PR gas/19109 * configure.ac: Add --enable-compressed-debug-sections={all,gas,gold,ld}. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@229088 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92412618916..cb6ca24458d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -393,6 +393,19 @@ case "${ENABLE_LD}" in
;;
esac
+# PR gas/19109
+# Decide the default method for compressing debug sections.
+# Provide a configure time option to override our default.
+AC_ARG_ENABLE(compressed_debug_sections,
+[AS_HELP_STRING([--enable-compressed-debug-sections={all,gas,gold,ld}],
+ [Enable compressed debug sections for gas, gold or ld by
+ default])],
+[
+ if test x"$enable_compressed_debug_sections" = xyes; then
+ AC_MSG_ERROR([no program with compressed debug sections specified])
+ fi
+], [enable_compressed_debug_sections=])
+
# Configure extra directories which are host specific
case "${host}" in