summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2009-08-19 22:19:37 +0000
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>2009-08-19 22:19:37 +0000
commitcd2f377379015425539a6c10a7c5b2c043035439 (patch)
tree3c87f798687a766a129c5e463c41722890b39c89 /configure.ac
parent1a48098b822d2eada9d586be83c667c62a9cca54 (diff)
downloadgcc-cd2f377379015425539a6c10a7c5b2c043035439.tar.gz
Disable option checking in the toplevel, avoid 2.64 fopen glitch.
/: * configure.ac: Call AC_DISABLE_OPTION_CHECKING. (baseargs): Add --disable-option-checking. * configure: Regenerate. config/: * override.m4 (AC_DISABLE_OPTION_CHECKING): Define to be empty if not defined, to avoid error with 2.59. (_AC_LANG_IO_PROGRAM): When the Autoconf version is exactly 2.64, avoid per-language instances to drop fopen from test program. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@150945 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7508758f01f..9da0048969a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@ m4_include(config/proginstall.m4)
AC_INIT(move-if-change)
AC_PREREQ(2.59)
+AC_DISABLE_OPTION_CHECKING
progname=$0
# if PWD already has a value, it is probably wrong.
@@ -2662,6 +2663,7 @@ baseargs="$baseargs --program-transform-name='${gcc_transform_name}'"
if test "$silent" = yes; then
baseargs="$baseargs --silent"
fi
+baseargs="$baseargs --disable-option-checking"
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor