summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2010-05-06 21:53:42 +0000
committerspop <spop@138bc75d-0d04-0410-961f-82ee72b054a4>2010-05-06 21:53:42 +0000
commit896fc76180ff179f9db46cda9c6dba9ee7286ac0 (patch)
tree745d96a240a03e168c5c572928a1593ab8158f24 /configure.ac
parent0ef84e3b6536aac0854c6538d6a46b6c587d94b6 (diff)
downloadgcc-896fc76180ff179f9db46cda9c6dba9ee7286ac0.tar.gz
Allow all the versions greater than 0.10 of PPL.
2010-05-05 Sebastian Pop <sebastian.pop@amd.com> * configure.ac: Allow all the versions greater than 0.10 of PPL. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@159134 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ba690241e35..f3ef304b9b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1531,8 +1531,6 @@ AC_ARG_WITH(boot-ldflags,
AC_SUBST(poststage1_ldflags)
# Check for PPL
-ppl_major_version=0
-ppl_minor_version=10
ppllibs=" -lppl_c -lppl -lgmpxx"
pplinc=
@@ -1573,9 +1571,9 @@ ENABLE_PPL_CHECK=yes)
if test "x$with_ppl" != "xno" -a "${ENABLE_PPL_CHECK}" = "yes"; then
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $pplinc $gmpinc"
- AC_MSG_CHECKING([for version $ppl_major_version.$ppl_minor_version of PPL])
+ AC_MSG_CHECKING([for version 0.10 (or later revision) of PPL])
AC_TRY_COMPILE([#include "ppl_c.h"],[
- #if PPL_VERSION_MAJOR != $ppl_major_version || PPL_VERSION_MINOR != $ppl_minor_version
+ #if PPL_VERSION_MAJOR != 0 || PPL_VERSION_MINOR < 10
choke me
#endif
], [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); ppllibs= ; pplinc= ; with_ppl=no ])