summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbje <bje@138bc75d-0d04-0410-961f-82ee72b054a4>2007-08-13 01:24:29 +0000
committerbje <bje@138bc75d-0d04-0410-961f-82ee72b054a4>2007-08-13 01:24:29 +0000
commitaf7bb0c07071dd8ce5d9ea04ff7a45de19795e53 (patch)
treedadc8542699d5324256bcac1657e84c15bc63c8b /configure.ac
parente2022c45b6aca10459d76f206db753c125593def (diff)
downloadgcc-af7bb0c07071dd8ce5d9ea04ff7a45de19795e53.tar.gz
* configure.ac (TOPLEVEL_CONFIGURE_ARGUMENTS, baseargs): Pass
--silent if $silent. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@127390 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2500cc6f351..8f957f4cdcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,9 @@ do
# Add the quoted argument to the list.
TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS $ac_arg"
done
+if test "$silent" = yes; then
+ TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS --silent"
+fi
# Remove the initial space we just introduced and, as these will be
# expanded by make, quote '$'.
TOPLEVEL_CONFIGURE_ARGUMENTS=`echo "x$TOPLEVEL_CONFIGURE_ARGUMENTS" | sed -e 's/^x *//' -e 's,\\$,$$,g'`
@@ -2178,6 +2181,9 @@ EOF_SED
gcc_transform_name=`cat conftestsed.out`
rm -f conftestsed.out
baseargs="$baseargs --program-transform-name='${gcc_transform_name}'"
+if test "$silent" = yes; then
+ baseargs="$baseargs --silent"
+fi
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor