summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2011-07-16 08:33:10 +0000
committerdoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2011-07-16 08:33:10 +0000
commitd7e52ac92ed645bd46f17e825fc48044e8e33cf0 (patch)
tree6e066c2cfa4ca80015b011442cf5a920b489b3e5 /configure.ac
parentcf797b5e23a26039497346da079319716eeadc2b (diff)
downloadgcc-d7e52ac92ed645bd46f17e825fc48044e8e33cf0.tar.gz
gcc/
2011-07-16 Matthias Klose <doko@ubuntu.com> * doc/install.texi: Document --enable-static-libjava. <toplevel> 2011-07-16 Matthias Klose <doko@ubuntu.com> * Makefile.tpl (EXTRA_CONFIGARGS_LIBJAVA): Define. * Makefile.def (target_modules/libjava): Pass $(EXTRA_CONFIGARGS_LIBJAVA). * configure.ac: Pass --disable-static in EXTRA_CONFIGARGS_LIBJAVA, if not configured with --enable-static-libjava. * Makefile.in: Regenerate. * configure: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@176351 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31a5bdf67bd..7085eeaf235 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,6 +443,20 @@ no)
;;
esac
+AC_ARG_ENABLE(static-libjava,
+[AS_HELP_STRING([[--enable-static-libjava[=ARG]]],
+ [build static libjava @<:@default=no@:>@])],
+ENABLE_STATIC_LIBJAVA=$enableval,
+ENABLE_STATIC_LIBJAVA=no)
+enable_static_libjava=
+if test "${ENABLE_STATIC_LIBJAVA}" = "yes" ; then
+ enable_static_libjava=yes
+fi
+
+if test x$enable_static_libjava != xyes ; then
+ EXTRA_CONFIGARGS_LIBJAVA=--disable-static
+fi
+AC_SUBST(EXTRA_CONFIGARGS_LIBJAVA)
# Disable libmudflap on some systems.
if test x$enable_libmudflap = x ; then