summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2002-10-03 19:06:16 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2002-10-03 19:06:16 +0000
commit0e26095bdbd8bcb6145d3498ef15954e44f30f5f (patch)
tree95ee982c244588ae7cd008fc2b8a7362f4c87612 /configure.in
parent949b0daae662e40e8609385a48fdc9b933e8442f (diff)
downloadgcc-0e26095bdbd8bcb6145d3498ef15954e44f30f5f.tar.gz
2002-10-03 Nathanael Nerode <neroden@gcc.gnu.org>
* Makefile.tpl: Make SET_LIB_PATH substitution more autoconfy. * configure.in: Make SET_LIB_PATH substitution more autoconfy. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@57783 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 98f56c34ebf..8988bef2782 100644
--- a/configure.in
+++ b/configure.in
@@ -1321,11 +1321,13 @@ esac
# If --enable-shared was set, we must set LD_LIBRARY_PATH so that the
# binutils tools will find libbfd.so.
if test "${shared}" = "yes" ; then
- sed -e 's/^SET_LIB_PATH[ ]*=.*$/SET_LIB_PATH = $(REALLY_SET_LIB_PATH)/' \
- Makefile > Makefile.tem
- rm -f Makefile
- mv -f Makefile.tem Makefile
+ SET_LIB_PATH="\$(REALLY_SET_LIB_PATH)"
+else
+ SET_LIB_PATH=
fi
+sed -e "s/@SET_LIB_PATH@/${SET_LIB_PATH}/" Makefile > Makefile.tem
+rm -f Makefile
+mv -f Makefile.tem Makefile
case "${host}" in