summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2000-09-02 07:18:09 +0000
committeraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2000-09-02 07:18:09 +0000
commite2bac683a0e10b1edf3e65220770f2a602e05ea2 (patch)
tree7bffa7150cebc6de50038272a69545c8bf311c7c /configure.in
parent9cdfb95df0b47fc1c5a9c826a4e748701fba05c9 (diff)
downloadgcc-e2bac683a0e10b1edf3e65220770f2a602e05ea2.tar.gz
* configure.in (FLAGS_FOR_TARGET): Use -nostdinc even for Canadian
crosses, but add gcc/include to the header search path for them. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@36113 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 55b853c3914..87e8a2a0750 100644
--- a/configure.in
+++ b/configure.in
@@ -1244,11 +1244,27 @@ case " $skipdirs " in
FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup -L$$r/$(TARGET_SUBDIR)/winsup/cygwin -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/include -isystem $$s/winsup/cygwin/include -isystem $$s/winsup/w32api/include -isystem $$s/newlib/libc/sys/cygwin -isystem $$s/newlib/libc/sys/cygwin32' ;;
esac
- # If we're using a pre-built compiler (which is the case for
- # Canadian crosses or when gcc isn't being built), don't discard
- # standard headers.
- if test "${build}" = "${host}" && test -d ${topsrcdir}/gcc; then
+ # If we're not building GCC, don't discard standard headers.
+ if test -d ${topsrcdir}/gcc; then
FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -nostdinc'
+
+ if test "${build}" != "${host}"; then
+ # On Canadian crosses, CC_FOR_TARGET will have already been set
+ # by `configure', so we won't have an opportunity to add -Bgcc/
+ # to it. This is right: we don't want to search that directory
+ # for binaries, but we want the header files in there, so add
+ # them explicitly.
+ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -isystem $$r/gcc/include'
+
+ # Someone might think of using the pre-installed headers on
+ # Canadian crosses, in case the installed compiler is not fully
+ # compatible with the compiler being built. In this case, it
+ # would be better to flag an error than risking having
+ # incompatible object files being constructed. We can't
+ # guarantee that an error will be flagged, but let's hope the
+ # compiler will do it, when presented with incompatible header
+ # files.
+ fi
fi
# If we're building newlib, use its generic headers last, but search