summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-31 11:56:46 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-31 11:56:46 +0000
commit145b0ed135ab825570329d97ffc4f881bd5b2fc0 (patch)
tree1bd09a73712c40d7c7750282692a1f094c832bba /configure.in
parent8ec3c5c2f80dd6d2561899354c2d9d1d66551f12 (diff)
downloadgcc-145b0ed135ab825570329d97ffc4f881bd5b2fc0.tar.gz
2006-01-31 Richard Guenther <rguenther@suse.de>
Paolo Bonzini <bonzini@gnu.org> * Makefile.def (target_modules): Add libgcc-math target module. * configure.in (target_libraries): Add libgcc-math target library. (--enable-libgcc-math): New configure switch. * Makefile.in: Re-generate. * configure: Re-generate. * libgcc-math: New toplevel directory. * doc/install.texi (--disable-libgcc-math): Document. libgcc-math/ * configure.ac: New file. * Makefile.am: Likewise. * configure: New generated file. * Makefile.in: Likewise. * aclocal.m4: Likewise. * libtool-version: New file. * include/ieee754.h: New file. * include/libc-symbols.h: Likewise. * include/math_private.h: Likewise. * i386/Makefile.am: New file. * i386/Makefile.in: New generated file. * i386/sse2.h: New file. * i386/endian.h: Likewise. * i386/sse2.map: Linker script for SSE2 ABI math intrinsics. * flt-32/: Import from glibc. * dbl-64/: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@110434 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index eddb5d80a09..0eddff8fb2c 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,7 @@ target_libraries="target-libiberty \
target-libstdc++-v3 \
target-libmudflap \
target-libssp \
+ target-libgcc-math \
target-libgfortran \
${libgcj} \
target-libobjc \
@@ -316,6 +317,21 @@ if test "${ENABLE_LIBSSP}" != "yes" ; then
noconfigdirs="$noconfigdirs target-libssp"
fi
+# Set the default so we build libgcc-math for ix86 and x86_64
+AC_ARG_ENABLE(libgcc-math,
+[ --enable-libgcc-math Builds libgcc-math directory],,
+[
+case "${target}" in
+ i?86-* | x86_64-* )
+ enable_libgcc_math=yes ;;
+ *)
+ enable_libgcc_math=no ;;
+esac
+])
+if test "${enable_libgcc_math}" != "yes"; then
+ noconfigdirs="$noconfigdirs target-libgcc-math"
+fi
+
# Save it here so that, even in case of --enable-libgcj, if the Java
# front-end isn't enabled, we still get libgcj disabled.
libgcj_saved=$libgcj