summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authoraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-25 21:29:48 +0000
committeraoliva <aoliva@138bc75d-0d04-0410-961f-82ee72b054a4>2001-04-25 21:29:48 +0000
commitf7ec7829962eb73d3034969b796ae41568783952 (patch)
treeb7409db7c0637db1cbc00703684ba536b3054bdd /configure.in
parent1fe57f2498d2757c2bc74b91460eb324d3acbf8b (diff)
downloadgcc-f7ec7829962eb73d3034969b796ae41568783952.tar.gz
* configure.in (libgcj_saved): Copy from $libgcj.
(libgcj): Zero out if --enable-libgcj; add to noconfigdirs is --disable-libgcj. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@41551 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d9f2bb15c4a..056d7d22489 100644
--- a/configure.in
+++ b/configure.in
@@ -585,6 +585,22 @@ case "${host}" in
;;
esac
+# Save it here so that, even in case of --enable-libgcj, if the Java
+# front-end isn't enabled, we still get libgcj disabled.
+libgcj_saved=$libgcj
+case $enable_libgcj in
+yes)
+ # If we reset it here, it won't get added to noconfigdirs in the
+ # target-specific build rules, so it will be forcibly enabled
+ # (unless the Java language itself isn't enabled).
+ libgcj=
+ ;;
+no)
+ # Make sure we get it printed in the list of not supported target libs.
+ noconfigdirs="$noconfigdirs ${libgcj}"
+ ;;
+esac
+
case "${target}" in
*-*-chorusos)
noconfigdirs="$noconfigdirs target-newlib target-libgloss ${libgcj}"