summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2005-12-19 17:02:00 +0000
committerbonzini <bonzini@138bc75d-0d04-0410-961f-82ee72b054a4>2005-12-19 17:02:00 +0000
commit9d44a80215cae63598a3982edd1a67d23bd9f725 (patch)
treedbc4d0e6c6c37767de48ab0e18bb5be443b2a8e2 /configure.in
parent1d13311084125d7622e74f9d2118e7ff704818b6 (diff)
downloadgcc-9d44a80215cae63598a3982edd1a67d23bd9f725.tar.gz
2005-12-19 Paolo Bonzini <bonzini@gnu.org>
* configure.in: Select appropriate fragments for PowerPC/AIX. * configure: Regenerate. * Makefile.def (flags_to_pass): Add ADAFLAGS, BOOT_ADAFLAGS, BOOT_CFLAGS, BOOT_LDFLAGS. * Makefile.tpl (POSTSTAGE1_FLAGS_TO_PASS): Handle BOOT_ADAFLAGS, BOOT_CFLAGS, BOOT_LDFLAGS. (TARGET_FLAGS_TO_PASS): Handle ADAFLAGS_FOR_TARGET. (stage[+id+]-bubble): Pass flags recursively to the comparison target. (stage): Fail if we cannot complete the work. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@108793 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 53973528cb3..b65ec91bbc4 100644
--- a/configure.in
+++ b/configure.in
@@ -967,6 +967,12 @@ case "${host}" in
powerpc-*-darwin*)
host_makefile_frag="config/mh-ppc-darwin"
;;
+ powerpc-*-aix*)
+ host_makefile_frag="config/mh-ppc-aix"
+ ;;
+ rs6000-*-aix*)
+ host_makefile_frag="config/mh-ppc-aix"
+ ;;
*-*-lynxos*)
# /bin/cc is less than useful for our purposes. Always use GCC
tentative_cc="/bin/gcc"
@@ -1513,6 +1519,7 @@ case "${target}" in
# harmless if we're using GNU nm or ar.
extra_arflags_for_target=" -X32_64"
extra_nmflags_for_target=" -B -X32_64"
+ target_makefile_frag="config/mt-ppc-aix"
;;
*-*-darwin*)
# ranlib from Darwin requires the -c flag to look at common symbols.